summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-06-19 12:48:34 +0100
committerMatthew Smith <matthew@gentoo.org>2022-06-19 12:55:57 +0100
commit4ce742f40797ee20d1da425dd80552f3be901912 (patch)
tree56537824809aebcade6f4d45c9d17fd3e97cb3d2 /app-emacs/setup
parentnet-im/skypeforlinux: drop 8.79.0.95 (diff)
downloadgentoo-4ce742f40797ee20d1da425dd80552f3be901912.tar.gz
gentoo-4ce742f40797ee20d1da425dd80552f3be901912.tar.bz2
gentoo-4ce742f40797ee20d1da425dd80552f3be901912.zip
app-emacs/setup: add 1.3.0
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'app-emacs/setup')
-rw-r--r--app-emacs/setup/Manifest1
-rw-r--r--app-emacs/setup/setup-1.3.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/setup/Manifest b/app-emacs/setup/Manifest
index d34c9d677d34..b4db34aaf6b7 100644
--- a/app-emacs/setup/Manifest
+++ b/app-emacs/setup/Manifest
@@ -1 +1,2 @@
DIST setup-1.2.0.tar.gz 19709 BLAKE2B 704340f9ab8a3e10fdeafed88365fb3151fe8c9600960defcce0021850a1846ffc5e7a3c02a4567371c18b4bdf5b81c80544fe82c22a150ca4d4505818ba8148 SHA512 705e188876316eb76938229395676a9068e735074d63865dd9a2a21d83face2768f958f76cf9c88b6cb3d4668e271ee043d7aa81a40d3b384fb1bc75bb1f0af5
+DIST setup-1.3.0.tar.gz 20112 BLAKE2B 7e8b29c6a2be68572ede8845bc1cdfc8e00acdaf1db972124ab18f2ec6ab216a481dc4c40ff256e7bdefd2558cafb686af8a51728e0b1c093ca369fa4a093c09 SHA512 cd088dba4f258a3440ec78e5742b6a2f5d1dba46e3382ea3b40967b640c80fd292b7edc1421f07561c270c4404d95c0fd55bd166265c79c131e0037f2181cb66
diff --git a/app-emacs/setup/setup-1.3.0.ebuild b/app-emacs/setup/setup-1.3.0.ebuild
new file mode 100644
index 000000000000..364818701e67
--- /dev/null
+++ b/app-emacs/setup/setup-1.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=26
+
+# The upstream does not create git tags for releases.
+MY_HASH=eece09d1151fd641f31d738b8c62742918993e95
+
+inherit elisp
+
+DESCRIPTION="Macro to simplify repetitive configuration patterns"
+HOMEPAGE="https://git.sr.ht/~pkal/setup"
+SRC_URI="https://git.sr.ht/~pkal/${PN}/archive/${MY_HASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_HASH}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}