summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-04-14 22:03:37 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-14 23:57:34 +0200
commit4c6bbb92f95412435cb8d66339ffe2b3ca81a8f0 (patch)
tree85da00b88f3da3d36da568bc1d2ae8a0de636ad3 /app-emacs
parentsys-kernel/git-sources: add 6.9_rc4 (diff)
downloadgentoo-4c6bbb92f95412435cb8d66339ffe2b3ca81a8f0.tar.gz
gentoo-4c6bbb92f95412435cb8d66339ffe2b3ca81a8f0.tar.bz2
gentoo-4c6bbb92f95412435cb8d66339ffe2b3ca81a8f0.zip
app-emacs/helm: bump to 3.9.8
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/helm/Manifest1
-rw-r--r--app-emacs/helm/helm-3.9.8.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/helm/Manifest b/app-emacs/helm/Manifest
index 4d475b67e5db..102fbd18c966 100644
--- a/app-emacs/helm/Manifest
+++ b/app-emacs/helm/Manifest
@@ -1 +1,2 @@
DIST helm-3.9.7.tar.gz 2377502 BLAKE2B e2936c7187e49909fbb6dd2bb703eeeab9d003b90a193c2fd0dc32c507d83766d38b0df1fa3d01571eac4d7c69c469a3842288dcf37e951a6d96bde7d4540242 SHA512 7f4b9020539091a2f7bb9c96602a9b6f35f44ff9ad46ffc332687704c3215cf6f394809c9794d868d246645d3192b50a5152d2b53fb1e0dcb741c23529523bd6
+DIST helm-3.9.8.tar.gz 2383635 BLAKE2B a6f1efd23ecb6b8156e46b936008de41fbc05e78fd5559a182a703cdfbec590a0409042f33e5d86f77ae969954057b4f2da7720e81db308cd3f3f301826cd9dd SHA512 ce574bb4e1534edc3442adb8b2257fe4e072db9736cc4e265f34e0b6aebd08cf4c599058755a4c453ba14dfa48499c423e549d1189f708b7fa2f048a229ada8f
diff --git a/app-emacs/helm/helm-3.9.8.ebuild b/app-emacs/helm/helm-3.9.8.ebuild
new file mode 100644
index 000000000000..29c9049d8925
--- /dev/null
+++ b/app-emacs/helm/helm-3.9.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/
+ https://github.com/emacs-helm/helm/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacs-helm/${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/async
+ app-emacs/popup
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-3.8.8-no-autoload-check.patch" )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ exeinto /usr/bin/
+ doexe emacs-helm.sh
+}