summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-04 09:23:53 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-04 09:43:28 +0100
commit5ce48d05a33514dc64a7f8940ac48b262a196614 (patch)
tree7db2d30b11b363c4ae8364035e0626738273068c /app-emacs
parentapp-emacs/corfu: drop old 0.37 (diff)
downloadgentoo-5ce48d05a33514dc64a7f8940ac48b262a196614.tar.gz
gentoo-5ce48d05a33514dc64a7f8940ac48b262a196614.tar.bz2
gentoo-5ce48d05a33514dc64a7f8940ac48b262a196614.zip
app-emacs/corfu: bump to 1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/corfu/Manifest1
-rw-r--r--app-emacs/corfu/corfu-1.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/corfu/Manifest b/app-emacs/corfu/Manifest
index e1e9c4fc4756..0502ef7cfbb2 100644
--- a/app-emacs/corfu/Manifest
+++ b/app-emacs/corfu/Manifest
@@ -1 +1,2 @@
DIST corfu-0.38.tar.gz 47354 BLAKE2B d36e07d494f56a91070f365801e47fb57b2e90a02e1dca325e795cc9158bf9baf577e413402592663ef66ab722e9750a1abb186816e93332f68d3a8a2bd72819 SHA512 40016e0b65a2ec9787ea236d6a6c5c499000ef7a07684a35bbe461edb5a975b6608cd82dbc3308c59e7e92076fe6fe2638cf253a8d53085f52d8d47e9e620f40
+DIST corfu-1.0.tar.gz 47770 BLAKE2B db1e0c2290836993c3f1ee44fa1f5eee8ba8f2b324d8d089a3240359f9a4503eb780429a70ec5aa4b88e3477cf98554a4c8b28c4359c19f16c1b6b14d35b1fb0 SHA512 13c14db66bc954257ef310ac07d2c33c2c0947e4f7774789d54469f16bbe910851b21e9dc73bf469077a1c23a563ae88457a7e64c2c60619fbf481b433c977ab
diff --git a/app-emacs/corfu/corfu-1.0.ebuild b/app-emacs/corfu/corfu-1.0.ebuild
new file mode 100644
index 000000000000..e1bbf4ca3ef1
--- /dev/null
+++ b/app-emacs/corfu/corfu-1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Completion Overlay Region FUnction"
+HOMEPAGE="https://github.com/minad/corfu/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.3.4"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}