summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-12-09 19:33:53 -0800
committerZac Medico <zmedico@gentoo.org>2019-12-09 19:34:08 -0800
commitbde22f207cc99be7f8b1c62a1f9461099fc9a6de (patch)
treecb79f770722e886eb1912f3737b4277ea41f8be5 /app-emulation/reg
parentapp-emulation/reg: LICENSE: account for vendored software (diff)
downloadgentoo-bde22f207cc99be7f8b1c62a1f9461099fc9a6de.tar.gz
gentoo-bde22f207cc99be7f8b1c62a1f9461099fc9a6de.tar.bz2
gentoo-bde22f207cc99be7f8b1c62a1f9461099fc9a6de.zip
app-emulation/reg: export -n GOCACHE
Closes: https://bugs.gentoo.org/680166 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation/reg')
-rw-r--r--app-emulation/reg/reg-0.16.1.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/app-emulation/reg/reg-0.16.1.ebuild b/app-emulation/reg/reg-0.16.1.ebuild
index 7a75f0dd2c52..bfd5ac25d064 100644
--- a/app-emulation/reg/reg-0.16.1.ebuild
+++ b/app-emulation/reg/reg-0.16.1.ebuild
@@ -35,8 +35,9 @@ src_prepare() {
}
src_compile() {
+ export -n GOCACHE GOPATH XDG_CACHE_HOME
pushd src/${EGO_PN} || die
- GOPATH="${S}" GO111MODULE=on go build -mod=vendor -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/reg . || die
+ GO111MODULE=on go build -mod=vendor -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/reg . || die
popd || die
}