summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-11-07 18:47:50 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-11-07 18:59:47 -0500
commitc61a33e9c6f517465fac77ae9995bb01ce000a36 (patch)
tree6288d3fc478f7ea1f44531540f09fe3402e390ae /app-emulation
parentlxqt-base/lxqt-meta: add 2.1.0 (diff)
downloadgentoo-c61a33e9c6f517465fac77ae9995bb01ce000a36.tar.gz
gentoo-c61a33e9c6f517465fac77ae9995bb01ce000a36.tar.bz2
gentoo-c61a33e9c6f517465fac77ae9995bb01ce000a36.zip
app-emulation/wine-proton: more clearly warn about lack of support
And repeat it every time rather than just on first install through the README.gentoo so that (hopefully) upstream Valve will not get more bug reports from here. Furthermore note that we also can't really do much about issues either and users seeking support should use normal Wine or normal Proton. Bug: https://bugs.gentoo.org/943001 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-proton/files/README.gentoo4
-rw-r--r--app-emulation/wine-proton/wine-proton-7.0.6.ebuild7
-rw-r--r--app-emulation/wine-proton/wine-proton-8.0.5c.ebuild7
-rw-r--r--app-emulation/wine-proton/wine-proton-9.0.2.ebuild7
-rw-r--r--app-emulation/wine-proton/wine-proton-9.0.3.ebuild7
-rw-r--r--app-emulation/wine-proton/wine-proton-9999.ebuild7
6 files changed, 35 insertions, 4 deletions
diff --git a/app-emulation/wine-proton/files/README.gentoo b/app-emulation/wine-proton/files/README.gentoo
index 0d88628a45ff..48f3d568a013 100644
--- a/app-emulation/wine-proton/files/README.gentoo
+++ b/app-emulation/wine-proton/files/README.gentoo
@@ -46,10 +46,6 @@ If have audio/video playback issues, note to look at GStreamer plugins.
Notably USE=ffmpeg on media-plugins/gst-plugins-meta which Proton normally
provide by default.
-Note that upstream may not be interested in bug reports without first
-reproducing using the actual Steam+Proton rather than this custom
-standalone build (esp. if lacking certain things like dxvk).
-
---
If have other Wine variants installed, remember to either use `eselect wine`
diff --git a/app-emulation/wine-proton/wine-proton-7.0.6.ebuild b/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
index 29b0e02ef24a..0885f72efe17 100644
--- a/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
+++ b/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
@@ -372,6 +372,13 @@ pkg_postinst() {
fi
fi
+ ewarn
+ ewarn "Warning: please consider ${PN} provided as-is without real"
+ ewarn "support. Upstream does not want bug reports unless can reproduce"
+ ewarn "with real Steam+Proton, and Gentoo is largely unable to help"
+ ewarn "unless it is a build/packaging issue. So, if need support, try"
+ ewarn "normal Wine or Proton instead."
+
eselect wine update --if-unset || die
}
diff --git a/app-emulation/wine-proton/wine-proton-8.0.5c.ebuild b/app-emulation/wine-proton/wine-proton-8.0.5c.ebuild
index cecd79a0c1f7..cd3bf6391ea7 100644
--- a/app-emulation/wine-proton/wine-proton-8.0.5c.ebuild
+++ b/app-emulation/wine-proton/wine-proton-8.0.5c.ebuild
@@ -389,6 +389,13 @@ pkg_postinst() {
fi
fi
+ ewarn
+ ewarn "Warning: please consider ${PN} provided as-is without real"
+ ewarn "support. Upstream does not want bug reports unless can reproduce"
+ ewarn "with real Steam+Proton, and Gentoo is largely unable to help"
+ ewarn "unless it is a build/packaging issue. So, if need support, try"
+ ewarn "normal Wine or Proton instead."
+
eselect wine update --if-unset || die
}
diff --git a/app-emulation/wine-proton/wine-proton-9.0.2.ebuild b/app-emulation/wine-proton/wine-proton-9.0.2.ebuild
index 17bdf7ebbeef..d8dfaa48476b 100644
--- a/app-emulation/wine-proton/wine-proton-9.0.2.ebuild
+++ b/app-emulation/wine-proton/wine-proton-9.0.2.ebuild
@@ -421,6 +421,13 @@ pkg_postinst() {
fi
fi
+ ewarn
+ ewarn "Warning: please consider ${PN} provided as-is without real"
+ ewarn "support. Upstream does not want bug reports unless can reproduce"
+ ewarn "with real Steam+Proton, and Gentoo is largely unable to help"
+ ewarn "unless it is a build/packaging issue. So, if need support, try"
+ ewarn "normal Wine or Proton instead."
+
eselect wine update --if-unset || die
}
diff --git a/app-emulation/wine-proton/wine-proton-9.0.3.ebuild b/app-emulation/wine-proton/wine-proton-9.0.3.ebuild
index 3895030f61ab..158df4efa795 100644
--- a/app-emulation/wine-proton/wine-proton-9.0.3.ebuild
+++ b/app-emulation/wine-proton/wine-proton-9.0.3.ebuild
@@ -421,6 +421,13 @@ pkg_postinst() {
fi
fi
+ ewarn
+ ewarn "Warning: please consider ${PN} provided as-is without real"
+ ewarn "support. Upstream does not want bug reports unless can reproduce"
+ ewarn "with real Steam+Proton, and Gentoo is largely unable to help"
+ ewarn "unless it is a build/packaging issue. So, if need support, try"
+ ewarn "normal Wine or Proton instead."
+
eselect wine update --if-unset || die
}
diff --git a/app-emulation/wine-proton/wine-proton-9999.ebuild b/app-emulation/wine-proton/wine-proton-9999.ebuild
index dc95b99493af..10f556feb152 100644
--- a/app-emulation/wine-proton/wine-proton-9999.ebuild
+++ b/app-emulation/wine-proton/wine-proton-9999.ebuild
@@ -423,6 +423,13 @@ pkg_postinst() {
fi
fi
+ ewarn
+ ewarn "Warning: please consider ${PN} provided as-is without real"
+ ewarn "support. Upstream does not want bug reports unless can reproduce"
+ ewarn "with real Steam+Proton, and Gentoo is largely unable to help"
+ ewarn "unless it is a build/packaging issue. So, if need support, try"
+ ewarn "normal Wine or Proton instead."
+
eselect wine update --if-unset || die
}