summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-09-03 22:58:29 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-09-03 22:58:29 +0900
commitbff78f62158a9dec6641401aae0cf5488d8c62f9 (patch)
tree7961c8de544ec1d86ea6490e8b7d71ea619e2e91 /app-i18n/ibus-hangul
parentapp-i18n/ibus-hangul: update LICENSE (diff)
downloadgentoo-bff78f62158a9dec6641401aae0cf5488d8c62f9.tar.gz
gentoo-bff78f62158a9dec6641401aae0cf5488d8c62f9.tar.bz2
gentoo-bff78f62158a9dec6641401aae0cf5488d8c62f9.zip
app-i18n/ibus-hangul: new upstream release
Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/ibus-hangul')
-rw-r--r--app-i18n/ibus-hangul/Manifest1
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.5.4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-i18n/ibus-hangul/Manifest b/app-i18n/ibus-hangul/Manifest
index 3bedf576f9e6..105124d7af34 100644
--- a/app-i18n/ibus-hangul/Manifest
+++ b/app-i18n/ibus-hangul/Manifest
@@ -1 +1,2 @@
DIST ibus-hangul-1.5.3.tar.gz 525834 BLAKE2B 6c92dbbde39bc42b7df974dbb23c9ef62088c8d3f63a500bd3c7e9c90b3d80d16dc1d76616620e1d7590fee549979a03585ac635761687dc11737d65fdf09e08 SHA512 ba21a8afb750e33744042c5e4f9d88891764921a37c4dbe1f4efa9883fd3c889789854af57adcd24bc1ca365ee49d2e01073c54d72cd025558b41788fb6213b4
+DIST ibus-hangul-1.5.4.tar.gz 542612 BLAKE2B 46495c04a37888a3ed21831b5bbca5b788f4d3a831fb3ce4eb13d95f302877fadddf831016f1d29aa2c1a6ba73fc0d585f2be57c10267a51a1a2186642632918 SHA512 dc4c755349424605de3832496a8a0cf7e8da577cbeff85d2b03da187fd5fdc9de5475eb523c69310e4f7edbb9a513f6f218de082ba32a25a477cdf5eb6f65513
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.5.4.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.5.4.ebuild
new file mode 100644
index 000000000000..1c7692b697c0
--- /dev/null
+++ b/app-i18n/ibus-hangul/ibus-hangul-1.5.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Korean Hangul engine for IBus"
+HOMEPAGE="https://github.com/libhangul/ibus-hangul/wiki"
+SRC_URI="https://github.com/libhangul/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ >=app-i18n/libhangul-0.1
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --with-python=${EPYTHON}
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}