summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/abduco
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/abduco')
-rw-r--r--app-misc/abduco/Manifest2
-rw-r--r--app-misc/abduco/abduco-0.2.ebuild50
-rw-r--r--app-misc/abduco/abduco-0.3.ebuild50
-rw-r--r--app-misc/abduco/metadata.xml16
4 files changed, 118 insertions, 0 deletions
diff --git a/app-misc/abduco/Manifest b/app-misc/abduco/Manifest
new file mode 100644
index 000000000000..251c7889208f
--- /dev/null
+++ b/app-misc/abduco/Manifest
@@ -0,0 +1,2 @@
+DIST abduco-0.2.tar.gz 11499 SHA256 c8b75a903b0914dd7804d57566f571f3f5efa91e46482bfb4652400156a71912 SHA512 9e6bda1779c4eff43c0f8a44857dd3beb25948c0f0bf2ff6e12bc951655e5f5ed3304794d7966b2e1cbb2c9f3917c153a1393889791a5293bd13111e15c3db11 WHIRLPOOL b76a95c21e16946eff999a148c453a44f819423fb6ab8c3903c8266c6d805d779c7232f2aa49fc0e09a19e3b6a6448b8a6a3c178266934dd1a3dcaaa4370a07c
+DIST abduco-0.3.tar.gz 11978 SHA256 934bf0b9ae25fb3f71b775387b5f281bf7d175fea79c12ec28ffdbbbb95390d4 SHA512 0bbd3a52e256738d39edf8e73e43d72fd4bcf2d240f45b8287486910777310320e239e7d1abb523a37c573dc557a0e33bf5849aa34f50f261f50c27a80db7338 WHIRLPOOL 1741f3c8d47a4f745b0fa0bed79306ca2d7dba8a936c6e66c1773205809fa1cf12f33f4c9f488eaa3c31f57d21299f17ec092926539a4fd037ebf2619e0dfb85
diff --git a/app-misc/abduco/abduco-0.2.ebuild b/app-misc/abduco/abduco-0.2.ebuild
new file mode 100644
index 000000000000..d69623781671
--- /dev/null
+++ b/app-misc/abduco/abduco-0.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils savedconfig toolchain-funcs
+
+DESCRIPTION="lightweight session manager with {de,at}tach support"
+HOMEPAGE="http://www.brain-dump.org/projects/abduco/"
+SRC_URI="http://www.brain-dump.org/projects/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ sed -e 's:^PREFIX.*:PREFIX = /usr:' \
+ -e 's/-Os//' \
+ -e '/^CC/d' \
+ -i config.mk || die
+
+ sed -e "s/VERSION/${PV}/g" \
+ -i ${PN}.1 || die
+
+ sed -e '/@echo CC/d' \
+ -e 's|@${CC}|$(CC)|g' \
+ -i Makefile || die
+
+ restore_config config.def.h
+ epatch_user
+
+ tc-export CC
+}
+
+src_test() {
+ ./testsuite.sh || die
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+ doman ${PN}.1
+
+ save_config config.def.h
+}
diff --git a/app-misc/abduco/abduco-0.3.ebuild b/app-misc/abduco/abduco-0.3.ebuild
new file mode 100644
index 000000000000..8dcc0276128e
--- /dev/null
+++ b/app-misc/abduco/abduco-0.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils savedconfig toolchain-funcs
+
+DESCRIPTION="lightweight session manager with {de,at}tach support"
+HOMEPAGE="http://www.brain-dump.org/projects/abduco/"
+SRC_URI="http://www.brain-dump.org/projects/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ sed -e 's:^PREFIX.*:PREFIX = /usr:' \
+ -e 's/-Os//' \
+ -e '/^CC/d' \
+ -i config.mk || die
+
+ sed -e "s/VERSION/${PV}/g" \
+ -i ${PN}.1 || die
+
+ sed -e '/@echo CC/d' \
+ -e 's|@${CC}|$(CC)|g' \
+ -i Makefile || die
+
+ restore_config config.def.h
+ epatch_user
+
+ tc-export CC
+}
+
+src_test() {
+ ./testsuite.sh || die
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+ doman ${PN}.1
+
+ save_config config.def.h
+}
diff --git a/app-misc/abduco/metadata.xml b/app-misc/abduco/metadata.xml
new file mode 100644
index 000000000000..e062d001b116
--- /dev/null
+++ b/app-misc/abduco/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>hendrik@consetetur.de</email>
+ <name>Hendrik v. Raven (lorem_ipsum)</name>
+</maintainer>
+<maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+</maintainer>
+<longdescription lang="en">
+ abduco provides session management i.e. it allows programs to be run independently from its controlling terminal. That is programs can be detached - run in the background - and then later reattached. Together with dvtm it provides a simpler and cleaner alternative to tmux or screen.
+</longdescription>
+</pkgmetadata>