summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/logserial
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/logserial')
-rw-r--r--app-misc/logserial/Manifest1
-rw-r--r--app-misc/logserial/files/logserial-0.4.2-gentoo.patch30
-rw-r--r--app-misc/logserial/logserial-0.4.2.ebuild32
-rw-r--r--app-misc/logserial/metadata.xml13
4 files changed, 76 insertions, 0 deletions
diff --git a/app-misc/logserial/Manifest b/app-misc/logserial/Manifest
new file mode 100644
index 000000000000..717f2f9ab953
--- /dev/null
+++ b/app-misc/logserial/Manifest
@@ -0,0 +1 @@
+DIST logserial-0.4.2.tar.gz 9697 SHA256 7647e16a884d3596844893234d8f0c7cc517441e2f8d592e11af427b8f0fbf9a SHA512 63784f5f3b84c1fbf85e0b5295ab33c427626562d880de3202b792ad354f93d645d4c2ddb7dc38d48ee25a15df51f1544aa0abea45fccef333553492ed86e9ad WHIRLPOOL e05f47b38830624c00c45006e076bdf13b42428217e7b8f8f41b6e5a71eafe6ec2ab579bd16b2e55d9973e26692e1047e896da3a0c8da47863290f081448ad73
diff --git a/app-misc/logserial/files/logserial-0.4.2-gentoo.patch b/app-misc/logserial/files/logserial-0.4.2-gentoo.patch
new file mode 100644
index 000000000000..dd594e34f76a
--- /dev/null
+++ b/app-misc/logserial/files/logserial-0.4.2-gentoo.patch
@@ -0,0 +1,30 @@
+diff -ur logserial-0.4.2.orig/Makefile logserial-0.4.2/Makefile
+--- logserial-0.4.2.orig/Makefile 2003-04-12 19:41:07.000000000 +0300
++++ logserial-0.4.2/Makefile 2009-07-21 19:39:18.000000000 +0300
+@@ -5,22 +5,20 @@
+ # FUNCTION:
+ # Makefile for logserial
+
+-CC=gcc
++CC ?= gcc
+
+ NAME=logserial
+ VERSION=0.4.2
+
+ OBJS= logserial.o sysdep1.o
+
+-OPTIMIZE= -O3 -m486 -Wall -D_POSIX -D_SYSV -D_SELECT -D_HAVE_MACROS
+-DEBUG_FLAGS= #-g
+-
+-CFLAGS= $(DEBUG_FLAGS) $(OPTIMIZE)
++CFLAGS += -Wall
++CPPFLAGS += -D_POSIX -D_SYSV -D_SELECT -D_HAVE_MACROS
+
+ all: $(NAME)
+
+ $(NAME): $(OBJS)
+- $(CC) $(CFLAGS) -o $(NAME) $(OBJS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(CPPFLAGS) -o $(NAME) $(OBJS)
+
+ $(NAME).o: $(NAME).c
+
diff --git a/app-misc/logserial/logserial-0.4.2.ebuild b/app-misc/logserial/logserial-0.4.2.ebuild
new file mode 100644
index 000000000000..9964c0359672
--- /dev/null
+++ b/app-misc/logserial/logserial-0.4.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A tool for logging raw data from a serial device"
+HOMEPAGE="http://www.gtlib.cc.gatech.edu/pub/Linux/system/serial/logserial-0.4.2.lsm"
+SRC_URI="http://www.gtlib.cc.gatech.edu/pub/Linux/system/serial/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin logserial || die "dobin failed"
+ dodoc CHANGELOG README
+}
diff --git a/app-misc/logserial/metadata.xml b/app-misc/logserial/metadata.xml
new file mode 100644
index 000000000000..a8bc14fa4c0c
--- /dev/null
+++ b/app-misc/logserial/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <longdescription lang="en">
+ Package for loging incoming bytes on asynchronous serial ports. It was
+ written for loging calls on our telephone central, but you can use it
+ for any devices connected to serial ports.
+ </longdescription>
+</pkgmetadata>