summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/tomboy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/tomboy')
-rw-r--r--app-misc/tomboy/Manifest1
-rw-r--r--app-misc/tomboy/metadata.xml5
-rw-r--r--app-misc/tomboy/tomboy-1.14.1.ebuild61
3 files changed, 67 insertions, 0 deletions
diff --git a/app-misc/tomboy/Manifest b/app-misc/tomboy/Manifest
new file mode 100644
index 000000000000..6bbd89179c6d
--- /dev/null
+++ b/app-misc/tomboy/Manifest
@@ -0,0 +1 @@
+DIST tomboy-1.14.1.tar.xz 6681068 SHA256 f9e81fd9c9a9180e8ddcb4b9237ead0c842aa5b5ac21af87e97939e5015af018 SHA512 98f46faff05cc6a9f708c880ed5a40dfb91f8e496c3b8bd3b49545b8cc095e643bd677cdf36601c95e53639fdb723aa9ac3e79b5c34aed24c4009729fd390a30 WHIRLPOOL 89eefc434f1257f56c74e88c221b4b029d90e3aca609fbd92e3c00ccc43ed4466509dabda77e949ff040c0286ee54c22ec8eeb720f70add29e79413dffacdd5b
diff --git a/app-misc/tomboy/metadata.xml b/app-misc/tomboy/metadata.xml
new file mode 100644
index 000000000000..d35e9300c540
--- /dev/null
+++ b/app-misc/tomboy/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>
diff --git a/app-misc/tomboy/tomboy-1.14.1.ebuild b/app-misc/tomboy/tomboy-1.14.1.ebuild
new file mode 100644
index 000000000000..57f99e7d0d7e
--- /dev/null
+++ b/app-misc/tomboy/tomboy-1.14.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 mono
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="http://projects.gnome.org/tomboy/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="eds test"
+
+RDEPEND="
+ app-text/gtkspell:2
+ dev-dotnet/gconf-sharp:2
+ dev-dotnet/gtk-sharp:2
+ dev-dotnet/mono-addins[gtk]
+ dev-dotnet/dbus-sharp
+ dev-dotnet/dbus-sharp-glib
+ dev-lang/mono
+ dev-libs/atk:=
+ gnome-base/gconf:2
+ x11-libs/gtk+:2
+ eds? ( dev-libs/gmime:2.6[mono] )
+"
+DEPEND="${RDEPEND}
+ app-text/gnome-doc-utils
+ app-text/rarian
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_prepare() {
+ sed \
+ -e "s:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g" \
+ -i configure.in || die
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-panel-applet \
+ --disable-galago \
+ --disable-update-mimedb \
+ $(use_enable eds evolution) \
+ $(use_enable test tests)
+}
+
+src_compile() {
+ # Not parallel build safe due upstream bug #631546
+ MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_compile
+}