summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/kmymoney
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/kmymoney')
-rw-r--r--app-office/kmymoney/Manifest2
-rw-r--r--app-office/kmymoney/kmymoney-4.7.1.ebuild68
-rw-r--r--app-office/kmymoney/kmymoney-4.7.2.ebuild68
-rw-r--r--app-office/kmymoney/metadata.xml9
4 files changed, 147 insertions, 0 deletions
diff --git a/app-office/kmymoney/Manifest b/app-office/kmymoney/Manifest
new file mode 100644
index 000000000000..2e4d3608c1f6
--- /dev/null
+++ b/app-office/kmymoney/Manifest
@@ -0,0 +1,2 @@
+DIST kmymoney-4.7.1.tar.xz 20152980 SHA256 7749cbae146eb4adf5c92162c841ae321f971c5720bc32d0227a42a4dd4acfc4 SHA512 e1abc00a39051d4797a177dda353af251dbc79dac97e4f4443df015f2f18f397672e59d6bf74baa6e94f18d4f26f1aea27cdffc37a1d1e46a146d22daed9fe7e WHIRLPOOL f2e698a39204338aeccd8d3d411f2d36a76a68a7b314a4ad47798a305c3432f5dd5c51d35616d8ebdefcbe6b92b55d6fcabf661067bcf2b2e401f51006b8df04
+DIST kmymoney-4.7.2.tar.xz 20391472 SHA256 bfb2c29ff30988f46324c2dae197a06b58d07336a1947adc22bcfed3e554393d SHA512 43db5b3e52d21dee517c8fadccf120aed5854dc16cbd7e265c327149c3a0c900ec02de06a56a9f5b8ad4d04c15730916c79238a3cf2778911e9d8cc4a65afbb1 WHIRLPOOL 461ce894aedb653e696572068ec7a006c3c3fcc2c7493caf634052393bc5874d19e3a6e87e73fd6100316d9bfbfe65eba4d6c87ea2f3b11ea4b354fc91422db7
diff --git a/app-office/kmymoney/kmymoney-4.7.1.ebuild b/app-office/kmymoney/kmymoney-4.7.1.ebuild
new file mode 100644
index 000000000000..60803d2f2d57
--- /dev/null
+++ b/app-office/kmymoney/kmymoney-4.7.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="bs ca ca@valencia cs da de el en_GB es et eu fi fr gl
+hu it kk nds nl pl pt pt_BR ro ru sv uk zh_TW"
+KDE_HANDBOOK="optional"
+VIRTUALX_REQUIRED="test"
+VIRTUALDBUS_TEST="true"
+inherit kde4-base
+
+DESCRIPTION="Personal finance manager for KDE"
+HOMEPAGE="http://kmymoney2.sourceforge.net/"
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE="debug calendar doc hbci ofx quotes"
+
+COMMON_DEPEND="
+ app-crypt/gpgme
+ >=app-office/libalkimia-4.3.2
+ dev-libs/gmp:0
+ dev-libs/libgpg-error
+ $(add_kdebase_dep kdepimlibs)
+ x11-misc/shared-mime-info
+ calendar? ( dev-libs/libical:= )
+ hbci? (
+ >=net-libs/aqbanking-5.0.1
+ >=sys-libs/gwenhywfar-4.0.1[qt4]
+ )
+ ofx? ( >=dev-libs/libofx-0.9.4 )
+"
+RDEPEND="${COMMON_DEPEND}
+ quotes? ( dev-perl/Finance-Quote )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT_DESIGNER=OFF
+ $(cmake-utils_use_enable calendar LIBICAL)
+ $(cmake-utils_use_use doc DEVELOPER_DOC)
+ $(cmake-utils_use_enable hbci KBANKING)
+ $(cmake-utils_use_enable ofx LIBOFX)
+ )
+ kde4-base_src_configure
+}
+
+src_compile() {
+ kde4-base_src_compile
+
+ use doc && kde4-base_src_compile apidoc
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${BUILD_DIR}/apidocs/html/")
+ kde4-base_src_install
+}
diff --git a/app-office/kmymoney/kmymoney-4.7.2.ebuild b/app-office/kmymoney/kmymoney-4.7.2.ebuild
new file mode 100644
index 000000000000..5d43287ed8a0
--- /dev/null
+++ b/app-office/kmymoney/kmymoney-4.7.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="bs ca ca@valencia cs da de el en_GB es et eu fi fr gl
+hu it kk nds nl pl pt pt_BR ro ru sk sv tr uk zh_CN zh_TW"
+KDE_HANDBOOK="optional"
+VIRTUALX_REQUIRED="test"
+VIRTUALDBUS_TEST="true"
+inherit kde4-base
+
+DESCRIPTION="Personal finance manager for KDE"
+HOMEPAGE="http://kmymoney2.sourceforge.net/"
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug calendar doc hbci ofx quotes"
+
+COMMON_DEPEND="
+ app-crypt/gpgme
+ >=app-office/libalkimia-4.3.2
+ dev-libs/gmp:0
+ dev-libs/libgpg-error
+ $(add_kdebase_dep kdepimlibs)
+ x11-misc/shared-mime-info
+ calendar? ( dev-libs/libical:= )
+ hbci? (
+ >=net-libs/aqbanking-5.0.1
+ >=sys-libs/gwenhywfar-4.0.1[qt4]
+ )
+ ofx? ( >=dev-libs/libofx-0.9.4 )
+"
+RDEPEND="${COMMON_DEPEND}
+ quotes? ( dev-perl/Finance-Quote )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT_DESIGNER=OFF
+ $(cmake-utils_use_enable calendar LIBICAL)
+ $(cmake-utils_use_use doc DEVELOPER_DOC)
+ $(cmake-utils_use_enable hbci KBANKING)
+ $(cmake-utils_use_enable ofx LIBOFX)
+ )
+ kde4-base_src_configure
+}
+
+src_compile() {
+ kde4-base_src_compile
+
+ use doc && kde4-base_src_compile apidoc
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${BUILD_DIR}/apidocs/html/")
+ kde4-base_src_install
+}
diff --git a/app-office/kmymoney/metadata.xml b/app-office/kmymoney/metadata.xml
new file mode 100644
index 000000000000..a799634a4f53
--- /dev/null
+++ b/app-office/kmymoney/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="hbci">Enable HBCI support using <pkg>net-libs/aqbanking</pkg></flag>
+ <flag name="quotes">Enable Online Stock Quote retrieval</flag>
+ </use>
+</pkgmetadata>