summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2020-06-20 17:31:40 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-07-16 15:59:24 +0300
commitf04d5b34d0052fbc998d1de8fb1ee4337ebb1b3f (patch)
treef89673fdc1f233a1a1a6f5fc397d3139bcb22ba4 /app-pda/usbmuxd
parentapp-pda/libimobiledevice: version bump to 1.3.0 (diff)
downloadgentoo-f04d5b34d0052fbc998d1de8fb1ee4337ebb1b3f.tar.gz
gentoo-f04d5b34d0052fbc998d1de8fb1ee4337ebb1b3f.tar.bz2
gentoo-f04d5b34d0052fbc998d1de8fb1ee4337ebb1b3f.zip
app-pda/usbmuxd: version bump to 1.1.1
Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl> Closes: https://github.com/gentoo/gentoo/pull/16352 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-pda/usbmuxd')
-rw-r--r--app-pda/usbmuxd/Manifest1
-rw-r--r--app-pda/usbmuxd/usbmuxd-1.1.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-pda/usbmuxd/Manifest b/app-pda/usbmuxd/Manifest
index 7c2c79565f0f..aae860d6845d 100644
--- a/app-pda/usbmuxd/Manifest
+++ b/app-pda/usbmuxd/Manifest
@@ -1,2 +1,3 @@
DIST usbmuxd-1.1.0.tar.bz2 321897 BLAKE2B 3ca5d1da222e457ac01f3e87fb7573c6405e51fd5d270a2b3dab7601118f21be22232d5100b4d027273fc837e6a57f7a7d17d2c41ae59d7c5aa41f76bef5a03d SHA512 66aa0c40e912bf596b819098b87d88e9cf30b2e6352e607eeb778bd4f23bf9bb123fb6a6ecca2d4e4be3171e35d66200d632d2c9c80b1f2462bb45be8aa6912d
+DIST usbmuxd-1.1.1.tar.bz2 345290 BLAKE2B 580dd4e2fb05d6c4803d774f7d43c8399219d8f0ce4191428cb4fccffcc941894d0381d5f0746997570dd24e395af3dda340b1910827f9c5ace7e2d9cc176c6a SHA512 0e8829c93aac147a6b949fe95592d6ad9ea36e1c04676cb85accb4670a65b31065706fc438556def17b55850081d6c07deb325ca02b9853335b6e0b1049ba1da
DIST usbmuxd-1.1.1_pre20200121.tar.bz2 51859 BLAKE2B 339d53904f7484bebb6d7524313ee065bf5a244efab16c77b30b8932071012105f21aa56083d82667b06088af83464ea8c86e3c28c5a45cb9abbe574a634533e SHA512 cc113b054e8e04d228af740ec43d2dbf29c015dc9d8e1cdd0eaf84bfcaa9838d5b1bf6db2efed30ffb84c35c88db5469983a115ffdbddbb6acd0df9fd2a5182f
diff --git a/app-pda/usbmuxd/usbmuxd-1.1.1.ebuild b/app-pda/usbmuxd/usbmuxd-1.1.1.ebuild
new file mode 100644
index 000000000000..bba79b98e7a8
--- /dev/null
+++ b/app-pda/usbmuxd/usbmuxd-1.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd udev
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="https://www.libimobiledevice.org/"
+SRC_URI="https://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+
+# src/utils.h is LGPL-2.1+, rest is found in COPYING*
+LICENSE="GPL-2 GPL-3 LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="systemd"
+
+DEPEND="
+ acct-user/usbmux
+ >=app-pda/libimobiledevice-1.0:=
+ >=app-pda/libplist-2.0:=
+ virtual/libusb:1"
+
+RDEPEND="
+ ${DEPEND}
+ virtual/udev
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with systemd) \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-udevrulesdir="$(get_udevdir)"/rules.d
+}