summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2024-03-08 15:03:51 +0100
committerDaniel Pielmeier <billie@gentoo.org>2024-03-08 15:03:51 +0100
commitc257fcccb4f94bc6af3b6f88503f401806b63396 (patch)
tree3a52ee8faf36704cc8a0e12e7f3e72292fdf2b1e /app-portage/pfl
parentmedia-sound/mac: destabilize 10.53 for ~amd64, ~ppc64, ~x86 (diff)
downloadgentoo-c257fcccb4f94bc6af3b6f88503f401806b63396.tar.gz
gentoo-c257fcccb4f94bc6af3b6f88503f401806b63396.tar.bz2
gentoo-c257fcccb4f94bc6af3b6f88503f401806b63396.zip
app-portage/pfl: add 3.5
Closes: https://bugs.gentoo.org/926417 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'app-portage/pfl')
-rw-r--r--app-portage/pfl/Manifest1
-rw-r--r--app-portage/pfl/pfl-3.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-portage/pfl/Manifest b/app-portage/pfl/Manifest
index ba8c9f3cfcab..c91b7f55f85f 100644
--- a/app-portage/pfl/Manifest
+++ b/app-portage/pfl/Manifest
@@ -1 +1,2 @@
DIST pfl-3.4.tar.gz 18651 BLAKE2B 09793883a1ed6f70da2f01fb81cfafa407ed43584a826f2cd8fde6d75b544ed803a220fc517e649774100da32e64d01fad8ff0dcbaff9068f57cdf7bd4414169 SHA512 c21b43f234a778d74e05cd45b7ccb48b131d6998e632d044a4bccc2f772099d02d1c5e7ab75fc6f9deb14e2f1ed1f31bac51e917e628065b4a36d73b8d77336f
+DIST pfl-3.5.tar.gz 20882 BLAKE2B 695867e9f612d49aa0d54830733403fa3351f8545b530243ba00cb72e73e258a2a3da5d6a3a9f4674d542ea8bf4994c56056f21aa385c5dfc3bb2f233cf47a39 SHA512 4c058cf3530c584cad03f11e19d7e102429d4150958cd14275e884c0ea7e5c205ecf0604858ccd65bbc60d0df8e385a2496909b049b24e8cb52a3a685349c38e
diff --git a/app-portage/pfl/pfl-3.5.ebuild b/app-portage/pfl/pfl-3.5.ebuild
new file mode 100644
index 000000000000..08f27aa7c608
--- /dev/null
+++ b/app-portage/pfl/pfl-3.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Searchable online file/package database for Gentoo"
+HOMEPAGE="https://www.portagefilelist.de https://github.com/portagefilelist/client"
+SRC_URI="https://github.com/portagefilelist/client/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+network-cron"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ sys-apps/portage[${PYTHON_USEDEP}]
+ network-cron? ( sys-apps/util-linux[caps] )
+"
+
+S="${WORKDIR}/client-${PV}"
+
+python_install_all() {
+ if use network-cron ; then
+ exeinto /etc/cron.weekly
+ doexe cron/pfl
+ fi
+
+ systemd_dounit systemd/pfl.{service,timer}
+
+ keepdir /var/lib/${PN}
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}/var/lib/${PN}/pfl.info" ]]; then
+ touch "${EROOT}/var/lib/${PN}/pfl.info" || die
+ fi
+ chown -R portage:portage "${EROOT}/var/lib/${PN}" || die
+ chmod 775 "${EROOT}/var/lib/${PN}" || die
+}