summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-shells/autojump
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-shells/autojump')
-rw-r--r--app-shells/autojump/Manifest3
-rw-r--r--app-shells/autojump/autojump-21.3.0-r1.ebuild61
-rw-r--r--app-shells/autojump/autojump-21.5.8-r1.ebuild59
-rw-r--r--app-shells/autojump/autojump-21.6.9.ebuild59
-rw-r--r--app-shells/autojump/files/autojump-21.3.0-supported-shells.patch34
-rw-r--r--app-shells/autojump/metadata.xml12
6 files changed, 228 insertions, 0 deletions
diff --git a/app-shells/autojump/Manifest b/app-shells/autojump/Manifest
new file mode 100644
index 000000000000..e6168c9d9374
--- /dev/null
+++ b/app-shells/autojump/Manifest
@@ -0,0 +1,3 @@
+DIST autojump-21.3.0.tar.gz 51261 SHA256 217398c3135647f223356e055a1b84adb470385584d743baf7fe4d519fd78252 SHA512 b0b0292a08d01005f09581c58bff2bf9b4b860b53602c0777bab7ef5a5b301993fe2bfef154bedadc75407bcc41e8de4a6f01d5b70e2e1be6b4ae6a6162d5196 WHIRLPOOL a218cde9345077af5c365b3e8eaff994606a0c29f2c8f3c6772b043e68decdc915bd353efc20c61f6de974d59c617c8a9b292fc465823b818882ac68f438869c
+DIST autojump-21.5.8.tar.gz 52170 SHA256 4e18585aac319da1c900f0f022a4fe8ce3e21257d440c034d7abf29ed42d4e1e SHA512 a3857e0195cc77f19bd4eb46b4fc96cd5f7b1c01dac35c1f928dde19198519fa4848c0cf7f8342f87a1f71617cfcad62cc495a711541f32bec807347e9b6bd01 WHIRLPOOL b7686d0d1332d4cbeec6d88a35951bae0cc513843b9fd34ff407e88cf0fdb8f616acb9e48d40a91b63cf4beea085f8fd6a4215d5e0b38599e47af8212f2eb2e2
+DIST autojump-21.6.9.tar.gz 50172 SHA256 8918817688a4e5f1e87e4e559a1bb5cd3fe43cb11222bb5283fd0f44d395464b SHA512 90f2d5fa3e8e272073a8dd00e6023f74d6e9159f5c4d5345fb3e2fbb4829262e0de18d64975dbd7b85bbbfb83f5706f4463f7370806516385cae48595113afff WHIRLPOOL 89e4bb6380396c50a7509050e192ab3dcaeef4861191760a75464cbed0deeecb071544d255d88d8139323abbf38c84f6418821437debf273d1f99d76e63c67bd
diff --git a/app-shells/autojump/autojump-21.3.0-r1.ebuild b/app-shells/autojump/autojump-21.3.0-r1.ebuild
new file mode 100644
index 000000000000..d7f8d981dd10
--- /dev/null
+++ b/app-shells/autojump/autojump-21.3.0-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit eutils python-r1 python-utils-r1 vcs-snapshot
+
+DESCRIPTION="change directory command that learns"
+HOMEPAGE="http://github.com/joelthelion/autojump"
+SRC_URI="https://github.com/joelthelion/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion python test zsh-completion"
+
+RDEPEND="bash-completion? ( >=app-shells/bash-4 )
+ python? ( ${PYTHON_DEPS} )
+ zsh-completion? ( app-shells/zsh app-shells/gentoo-zsh-completions )"
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-supported-shells.patch
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ dobin bin/autojump
+
+ insinto /etc/profile.d
+ doins bin/${PN}.sh
+
+ if use bash-completion ; then
+ doins bin/${PN}.bash
+ fi
+
+ if use zsh-completion ; then
+ doins bin/${PN}.zsh
+ insinto /usr/share/zsh/site-functions
+ doins bin/_j
+ fi
+
+ if use python ; then
+ python_foreach_impl python_domodule tools/autojump_ipython.py
+
+ einfo "This tool provides \"j\" for ipython, please add"
+ einfo "\"import autojump_ipython\" to your ipy_user_conf.py."
+ fi
+
+ doman docs/${PN}.1
+ dodoc README.md
+
+ elog "loading of insecure relative path \"custom_install\" has been"
+ elog "remove. See ${EPREFIX}/etc/profile.d/${PN}.sh for details."
+}
diff --git a/app-shells/autojump/autojump-21.5.8-r1.ebuild b/app-shells/autojump/autojump-21.5.8-r1.ebuild
new file mode 100644
index 000000000000..d6a53538ac55
--- /dev/null
+++ b/app-shells/autojump/autojump-21.5.8-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit python-r1 python-utils-r1 vcs-snapshot
+
+DESCRIPTION="change directory command that learns"
+HOMEPAGE="http://github.com/joelthelion/autojump"
+SRC_URI="https://github.com/joelthelion/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion python test zsh-completion"
+
+RDEPEND="bash-completion? ( >=app-shells/bash-4 )
+ python? ( ${PYTHON_DEPS} )
+ zsh-completion? ( app-shells/zsh app-shells/gentoo-zsh-completions )"
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+src_prepare() {
+ sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
+ -i bin/autojump.sh || die
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ dobin bin/autojump
+
+ insinto /etc/profile.d
+ doins bin/${PN}.sh
+
+ if use bash-completion ; then
+ doins bin/${PN}.bash
+ fi
+
+ if use zsh-completion ; then
+ doins bin/${PN}.zsh
+ insinto /usr/share/zsh/site-functions
+ doins bin/_j
+ fi
+
+ if use python ; then
+ python_foreach_impl python_domodule tools/autojump_ipython.py
+
+ einfo "This tool provides \"j\" for ipython, please add"
+ einfo "\"import autojump_ipython\" to your ipy_user_conf.py."
+ fi
+
+ doman docs/${PN}.1
+ dodoc README.md
+}
diff --git a/app-shells/autojump/autojump-21.6.9.ebuild b/app-shells/autojump/autojump-21.6.9.ebuild
new file mode 100644
index 000000000000..18a6c71d0afa
--- /dev/null
+++ b/app-shells/autojump/autojump-21.6.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit python-r1 python-utils-r1 vcs-snapshot
+
+DESCRIPTION="change directory command that learns"
+HOMEPAGE="http://github.com/joelthelion/autojump"
+SRC_URI="https://github.com/joelthelion/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion python test zsh-completion"
+
+RDEPEND="bash-completion? ( >=app-shells/bash-4 )
+ python? ( ${PYTHON_DEPS} )
+ zsh-completion? ( app-shells/zsh app-shells/gentoo-zsh-completions )"
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+src_prepare() {
+ sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
+ -i bin/autojump.sh || die
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ dobin bin/autojump
+
+ insinto /etc/profile.d
+ doins bin/${PN}.sh
+
+ if use bash-completion ; then
+ doins bin/${PN}.bash
+ fi
+
+ if use zsh-completion ; then
+ doins bin/${PN}.zsh
+ insinto /usr/share/zsh/site-functions
+ doins bin/_j
+ fi
+
+ if use python ; then
+ python_foreach_impl python_domodule tools/autojump_ipython.py
+
+ einfo "This tool provides \"j\" for ipython, please add"
+ einfo "\"import autojump_ipython\" to your ipy_user_conf.py."
+ fi
+
+ doman docs/${PN}.1
+ dodoc README.md
+}
diff --git a/app-shells/autojump/files/autojump-21.3.0-supported-shells.patch b/app-shells/autojump/files/autojump-21.3.0-supported-shells.patch
new file mode 100644
index 000000000000..a16fc2d4dcf2
--- /dev/null
+++ b/app-shells/autojump/files/autojump-21.3.0-supported-shells.patch
@@ -0,0 +1,34 @@
+--- autojump-21.3.0/bin/autojump.sh
++++ autojump-21.3.0/bin/autojump.sh
+@@ -1,17 +1,17 @@
+ # source autojump on BASH or ZSH depending on the shell
+
+ shell=`echo ${SHELL} | awk -F/ '{ print $NF }'`
+-
+-# check local install
+-if [ -s ~/.autojump/etc/profile.d/autojump.${shell} ]; then
+- source ~/.autojump/etc/profile.d/autojump.${shell}
+-
+-# check global install
+-elif [ -s /etc/profile.d/autojump.${shell} ]; then
+- source /etc/profile.d/autojump.${shell}
+-
+-# check custom install locations (modified by Homebrew or using --destdir option)
+-elif [ -s custom_install/autojump.${shell} ]; then
+- source custom_install/autojump.${shell}
+-
+-fi
++case ${shell} in
++ bash|zsh)
++ # check local install
++ if [ -s ~/.autojump/etc/profile.d/autojump.${shell} ]; then
++ source ~/.autojump/etc/profile.d/autojump.${shell}
++ # check global install
++ elif [ -s "${EPREFIX}"/etc/profile.d/autojump.${shell} ]; then
++ source "${EPREFIX}"/etc/profile.d/autojump.${shell}
++ fi
++ ;;
++ *)
++ echo "Your shell ${shell} (from SHELL=${SHELL}) is unkown."
++ ;;
++esac
diff --git a/app-shells/autojump/metadata.xml b/app-shells/autojump/metadata.xml
new file mode 100644
index 000000000000..93654722ae8a
--- /dev/null
+++ b/app-shells/autojump/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/joelthelion/autojump/issues</bugs-to>
+ <remote-id type="github">joelthelion/autojump</remote-id>
+ </upstream>
+</pkgmetadata>