summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-23 12:02:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-23 12:51:47 +0200
commit47d0de545f8987ba2f799d378fe5acc985d9d2d3 (patch)
treef2044f350e4b3fc0ebf1678c2a41a1d9bf82610c /app-text/dvisvgm
parentapp-text/dvipng: bump to 1.17 (diff)
downloadgentoo-47d0de545f8987ba2f799d378fe5acc985d9d2d3.tar.gz
gentoo-47d0de545f8987ba2f799d378fe5acc985d9d2d3.tar.bz2
gentoo-47d0de545f8987ba2f799d378fe5acc985d9d2d3.zip
app-text/dvisvgm: bump to 2.10.1
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'app-text/dvisvgm')
-rw-r--r--app-text/dvisvgm/Manifest1
-rw-r--r--app-text/dvisvgm/dvisvgm-2.10.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-text/dvisvgm/Manifest b/app-text/dvisvgm/Manifest
index 278b3445262c..69148bdcf829 100644
--- a/app-text/dvisvgm/Manifest
+++ b/app-text/dvisvgm/Manifest
@@ -1,3 +1,4 @@
DIST dvisvgm-2.1.3.tar.gz 2802278 BLAKE2B 36e523d4b82a71f26ebc50428c56863a3729d1cf79c63660a5a3cecdd7c55c27e7ad811121e8a2ccdaa37f1ec2fb345d1d5d4f7b59011be7877500df5dba1f48 SHA512 dfd6e94b28dcdf2d1be236f3f29eaf4e3e5b7bb34544cdd55ae09de612b02561dd782b693a9a94eea07420c795d31ef210eba34cb663d7de98f438c089369ff2
+DIST dvisvgm-2.10.1.tar.gz 3110061 BLAKE2B 3f3bb50baa587c1d20061d235885b4c921efbd3400aa7e4d2df872e37e0ef57d57ae4713fedfd0587d7fcffe7e0286ca55e319e6e82b3b72b49c5df5fa08f633 SHA512 8faa68b13a0e351ba54b5c9acb1dbda6e081eddd167b2cc599208cc2e7967c116c3d105d29df224165daff88f81acb3135d936ec9b2da4dce2c82c197f6a4e78
DIST dvisvgm-2.6.1.tar.gz 2911596 BLAKE2B 8dfe85140db4b462c1721a8bad322d52535a0fced4bb8c374c342bd4ca8fe5cf6dfa5751a8a8070b9ce622ab7bb7df14985802c596fdc387f90febc80151fbd6 SHA512 791183f92ec4733574614fd5b8b4247a7b766b62b1aa7b1444d508d0358178b1447b24fb51d09948d99552c2cb7ed3a0f9bce0416b66de8a4835f85476bbdb25
DIST dvisvgm-2.7.tar.gz 3037242 BLAKE2B f93bcc4220adf4b2c0d7e06deb11416f22c623f07c96ca9aa9093054e18ec72f8da1d93aa4ee467f82f9478bb0c1b8acebbb56de020f47563056dd0dbea5936e SHA512 b706085015d1ab4c9b88997cf6c1c93f6c0ee60c9d1429d3fba7bed7b5acb3392958f64b4207ae27e6eb52abb19ff9640e2b7459e4b19ae21986b82d4b65b182
diff --git a/app-text/dvisvgm/dvisvgm-2.10.1.ebuild b/app-text/dvisvgm/dvisvgm-2.10.1.ebuild
new file mode 100644
index 000000000000..dd9c838f52f0
--- /dev/null
+++ b/app-text/dvisvgm/dvisvgm-2.10.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Converts DVI files to SVG"
+HOMEPAGE="https://dvisvgm.de/"
+SRC_URI="https://github.com/mgieseki/dvisvgm/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+# Tests don't work from $WORKDIR: kpathsea tries to search in relative
+# directories from where the binary is executed.
+# We cannot really use absolute paths in the kpathsea configuration since that
+# would make it harder for prefix installs.
+RESTRICT="test"
+
+RDEPEND="virtual/tex-base
+ >=app-arch/brotli-1.0.5
+ app-text/ghostscript-gpl
+ dev-libs/kpathsea:=
+ >=dev-libs/xxhash-0.6.5
+ >=media-gfx/potrace-1.10-r1
+ media-libs/freetype:2
+ >=media-libs/woff2-1.0.2
+ dev-libs/kpathsea
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-text/xmlto
+ app-text/asciidoc
+ dev-libs/libxslt
+ virtual/pkgconfig
+ test? ( dev-cpp/gtest )"
+
+src_configure() {
+ local myargs=(
+ --without-ttfautohint
+ )
+ econf "${myargs[@]}"
+}