summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro_gentoo@matoro.tk>2024-01-27 00:15:35 -0500
committerSam James <sam@gentoo.org>2024-01-28 22:13:25 +0000
commit321559cd73ab1a4d01cb38b26544896618a062b4 (patch)
tree2c818052ddcbf14037f04bf4328d3d0761500522 /app-text/highlight
parentdev-util/itstool: enable py3.12 (diff)
downloadgentoo-321559cd73ab1a4d01cb38b26544896618a062b4.tar.gz
gentoo-321559cd73ab1a4d01cb38b26544896618a062b4.tar.bz2
gentoo-321559cd73ab1a4d01cb38b26544896618a062b4.zip
app-text/highlight: wire up tests
Bug: https://bugs.gentoo.org/921001 Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Closes: https://github.com/gentoo/gentoo/pull/35037 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/highlight')
-rw-r--r--app-text/highlight/Manifest1
-rw-r--r--app-text/highlight/highlight-4.9.ebuild15
2 files changed, 14 insertions, 2 deletions
diff --git a/app-text/highlight/Manifest b/app-text/highlight/Manifest
index f5802d9c528c..003099220e62 100644
--- a/app-text/highlight/Manifest
+++ b/app-text/highlight/Manifest
@@ -4,3 +4,4 @@ DIST highlight-4.8.tar.bz2 1492966 BLAKE2B f0bc746cb671037c2a5f1557c6114c143448d
DIST highlight-4.8.tar.bz2.asc 488 BLAKE2B 466905e2a4b1b577feba593e2d6e855e09764cdb08ddbd5aa3b4c62c4b06bc19a013df16aa1dfc81d4e52765641d5f98615233609d7b4f039f6f8c6a929d345a SHA512 929c5b0a25a2f5a0b9204afb03b5456b2b62d07e519799602b06a0ad2d4bc1d9eac92965571732b0eaffe780904321ebffb31cdf61b6fe644ecc39ddb983c7b8
DIST highlight-4.9.tar.bz2 1498248 BLAKE2B 09ff0a5cc81da45270a8382dc6b2a2d3b44d1f084e661fae4a3d39d2ded9af6c77b1fb0d51d32c59f22ccba1612ab7faf68b5e918dda70c9f2e25b29b5c44ecd SHA512 280abd98182c5b95f629ca126e8a59ca6bf6f9e301fc7678aa3e4cb37b714827dfdfab1e008c798e203c7408355be63e01e88f93eacfcf2c5fad95afc6e22112
DIST highlight-4.9.tar.bz2.asc 488 BLAKE2B cbd3541f65ec714ff1fda17fb141aa19f53952634a2027819fdbf50f7cf781f875b76ebd9a82119347f17940d8200f856082dfff51ff994a71a2ece04d654764 SHA512 04c2aca4050cae0dde97340a1ebafd968526e2d811e4551e8895acca50613f7e5902e31d735a0da1427d69e85e152530776fa1b9f5896efe410d8f9437768298
+DIST highlight-test-suite-a3479468672cdbc570a17ae84e047fe8f0b88798.tar.bz2 33310 BLAKE2B a06f2503fc571f5978f648fdc677f58f3fdfa759f9b5cf31a85d03589bbbfd2b56c7055517c59292369653503047af63d9c3bfbbe541a50bd2ea2adede28f60c SHA512 9583fe0af315e0dd1e37e137adf5c97a83832885a5a8a12b91790d7d7b0758c03fd76c02fbda368a2481eaec98f7b010a530bc31da98337d6fa7201aadb023ce
diff --git a/app-text/highlight/highlight-4.9.ebuild b/app-text/highlight/highlight-4.9.ebuild
index fd881ed2f465..85e9707adae5 100644
--- a/app-text/highlight/highlight-4.9.ebuild
+++ b/app-text/highlight/highlight-4.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,15 +9,19 @@ inherit lua-single qmake-utils toolchain-funcs verify-sig xdg
DESCRIPTION="Converts source code to formatted text (HTML, LaTeX, etc.) with syntax highlight"
HOMEPAGE="http://www.andre-simon.de/"
+# This is arbitrary; upstream uses master. Update when possible.
+TESTSUITE_COMMIT="a3479468672cdbc570a17ae84e047fe8f0b88798"
SRC_URI="
http://www.andre-simon.de/zip/${P}.tar.bz2
+ test? ( https://gitlab.com/tajmone/${PN}-test-suite/-/archive/${TESTSUITE_COMMIT}/${PN}-test-suite-${TESTSUITE_COMMIT}.tar.bz2 )
verify-sig? ( http://www.andre-simon.de/zip/${P}.tar.bz2.asc )
"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="examples gui"
+IUSE="examples gui test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="${LUA_REQUIRED_USE}"
@@ -97,6 +101,13 @@ src_compile() {
fi
}
+src_test() {
+ find "../${PN}-test-suite-${TESTSUITE_COMMIT}" -mindepth 1 -maxdepth 1 -type d | sort | while read line
+ do
+ "${SHELL}" "${line}/regression.sh" || die "Regression tests failed for language $(basename "${line}")"
+ done
+}
+
src_install() {
emake -f makefile "${myhlopts[@]}" install