summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2016-12-27 22:25:02 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-12-28 14:21:10 +0100
commit5cbf973742fbeb68a2b145d9631a1fa22804f677 (patch)
tree281d9cc91b78c965b53f3c7da7263adab8336cb6 /app-text/jabref-bin/jabref-bin-3.8.1.ebuild
parentapp-text/jabref-bin: update link to CHANGELOG. (diff)
downloadgentoo-5cbf973742fbeb68a2b145d9631a1fa22804f677.tar.gz
gentoo-5cbf973742fbeb68a2b145d9631a1fa22804f677.tar.bz2
gentoo-5cbf973742fbeb68a2b145d9631a1fa22804f677.zip
app-text/jabref-bin: version bump to 3.8.1.
Closes: https://github.com/gentoo/gentoo/pull/3260
Diffstat (limited to 'app-text/jabref-bin/jabref-bin-3.8.1.ebuild')
-rw-r--r--app-text/jabref-bin/jabref-bin-3.8.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/jabref-bin/jabref-bin-3.8.1.ebuild b/app-text/jabref-bin/jabref-bin-3.8.1.ebuild
new file mode 100644
index 000000000000..a4e2b5729851
--- /dev/null
+++ b/app-text/jabref-bin/jabref-bin-3.8.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils java-pkg-2
+
+MY_PV_1="${PV/_beta/b}"
+MY_PV="${MY_PV_1/_rc/}"
+MY_URI_PV_1="${PV/rc/}"
+MY_URI_PV="${MY_URI_PV_1//_/%20}"
+
+DESCRIPTION="Java GUI for managing BibTeX and other bibliographies"
+HOMEPAGE="http://www.jabref.org/"
+# SRC_URI="mirror://sourceforge/jabref/JabRef-${MY_PV}.jar"
+SRC_URI="https://github.com/JabRef/jabref/releases/download/v${PV}/JabRef-${MY_PV}.jar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+
+RDEPEND=">=virtual/jre-1.8"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${A}" . || die
+ unzip ${A} images/icons/JabRef-icon-48.png || die
+}
+
+src_install() {
+ java-pkg_newjar "JabRef-${MY_PV}.jar"
+ java-pkg_dolauncher "${PN}" --jar "${PN}.jar"
+ newicon images/icons/JabRef-icon-48.png JabRef-bin-icon.png
+ make_desktop_entry "${PN}" JabRef-bin JabRef-bin-icon Office
+}