summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-01-19 18:32:51 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-01-19 18:33:04 +0000
commit3a8ee12aee999c20ba97775d0e68541973c01859 (patch)
tree052f840f3050403f362e45f78d9fefa2e34dcd38 /app-text/lv
parentnet-misc/aria2: Removed old. (diff)
downloadgentoo-3a8ee12aee999c20ba97775d0e68541973c01859.tar.gz
gentoo-3a8ee12aee999c20ba97775d0e68541973c01859.tar.bz2
gentoo-3a8ee12aee999c20ba97775d0e68541973c01859.zip
app-text/lv: add missing string protos
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-text/lv')
-rw-r--r--app-text/lv/files/lv-4.51-protos.patch29
-rw-r--r--app-text/lv/lv-4.51-r3.ebuild3
2 files changed, 31 insertions, 1 deletions
diff --git a/app-text/lv/files/lv-4.51-protos.patch b/app-text/lv/files/lv-4.51-protos.patch
new file mode 100644
index 000000000000..602ef5f6117f
--- /dev/null
+++ b/app-text/lv/files/lv-4.51-protos.patch
@@ -0,0 +1,29 @@
+Add missing string protos.
+
+ * src/guess.c:150:12: warning: implicit declaration of function ‘strncmp’ [-Wimplicit-function-declaration]
+ * src/guess.c:218:22: warning: implicit declaration of function ‘strcmp’ [-Wimplicit-function-declaration]
+ * src/guesslocale.c:42:9: warning: implicit declaration of function ‘toupper’ [-Wimplicit-function-declaration]
+diff --git a/src/guess.c b/src/guess.c
+index facd95e..555acd3 100644
+--- a/src/guess.c
++++ b/src/guess.c
+@@ -21,6 +21,7 @@
+ */
+
+ #include <stdio.h>
++#include <string.h> /* strcmp */
+
+ #include <import.h>
+ #include <decode.h>
+diff --git a/src/guesslocale.c b/src/guesslocale.c
+index 7974c88..c259723 100644
+--- a/src/guesslocale.c
++++ b/src/guesslocale.c
+@@ -29,6 +29,7 @@
+ #include <langinfo.h>
+ #endif
+
++#include <ctype.h> /* toupper */
+ #include <import.h>
+ #include <ctable.h>
+ #include <begin.h>
diff --git a/app-text/lv/lv-4.51-r3.ebuild b/app-text/lv/lv-4.51-r3.ebuild
index c3c89a1a2e22..3e07c7f656aa 100644
--- a/app-text/lv/lv-4.51-r3.ebuild
+++ b/app-text/lv/lv-4.51-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -27,6 +27,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch
epatch "${FILESDIR}"/${P}-xz.diff
epatch "${FILESDIR}"/${P}-tinfo.patch
+ epatch "${FILESDIR}"/${P}-protos.patch
cd "${S}"/src; eautoreconf
}