summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-11-19 08:34:00 +0100
committerLars Wendler <polynomial-c@gentoo.org>2015-11-19 09:01:29 +0100
commit03e36fa1cc1bd1c601c665b73c231a8845ba5952 (patch)
treef2a88a7856c98717b4c47639d434ff1054c3bfbb /app-text/xmlto
parentwww-client/chromium: dev channel bump (48.0.2560.0); experimental GN support (diff)
downloadgentoo-03e36fa1cc1bd1c601c665b73c231a8845ba5952.tar.gz
gentoo-03e36fa1cc1bd1c601c665b73c231a8845ba5952.tar.bz2
gentoo-03e36fa1cc1bd1c601c665b73c231a8845ba5952.zip
app-text/xmlto: Bump to version 0.0.28
Package-Manager: portage-2.2.25 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-text/xmlto')
-rw-r--r--app-text/xmlto/Manifest1
-rw-r--r--app-text/xmlto/xmlto-0.0.28.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-text/xmlto/Manifest b/app-text/xmlto/Manifest
index c1167f5075a6..f93e1d10ce65 100644
--- a/app-text/xmlto/Manifest
+++ b/app-text/xmlto/Manifest
@@ -1 +1,2 @@
DIST xmlto-0.0.26.tar.bz2 119819 SHA256 efb49b2fb3bc27c1a1e24fe34abf19b6bf6cbb40844e6fd58034cdf21c54b5ec SHA512 85110f22a7b5a5c8de4115ae5d0391645a223191b17455a4f9539b02f56f7003fd4ba70e48f0e5e46cdb91220a9027802e725f88ca8659e3ce1576f8609ccd18 WHIRLPOOL f7ded4ceb65adcfc7c06bfdb8a3d22ca7195c098b5bcf26b3884111f536b72efbf5e642eeeee8be17d4a33db3accc139d78178dba2fe5a98037712048c2410e4
+DIST xmlto-0.0.28.tar.bz2 127921 SHA256 1130df3a7957eb9f6f0d29e4aa1c75732a7dfb6d639be013859b5c7ec5421276 SHA512 6e0c4968d4f1b7a3b132904182aa72a73f6167553eabdeb65cfafa6295ef7b960541685769d04144207963cca77b0c44db4f9fbb2796348ffcb37b3b399f18f1 WHIRLPOOL 4adbd66f85ed0ca90cb122dc08f9817d82e0b2bd417ae2ca8bb97e1fa3e301ab344d1ff9b9dec8571a6a519f1e0a80f0ce133d2618a211a64b0982c0b2b8c5f6
diff --git a/app-text/xmlto/xmlto-0.0.28.ebuild b/app-text/xmlto/xmlto-0.0.28.ebuild
new file mode 100644
index 000000000000..44dc5f34a096
--- /dev/null
+++ b/app-text/xmlto/xmlto-0.0.28.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="script for converting XML and DocBook formatted documents to a variety of output formats"
+HOMEPAGE="https://fedorahosted.org/xmlto/"
+SRC_URI="https://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="latex"
+
+RDEPEND=">=app-text/docbook-xsl-stylesheets-1.62.0-r1
+ app-text/docbook-xml-dtd:4.2
+ app-shells/bash:0=
+ dev-libs/libxslt
+ sys-apps/sed
+ || ( >=sys-apps/coreutils-6.10-r1 sys-freebsd/freebsd-ubin )
+ || ( sys-apps/util-linux app-misc/getopt )
+ || ( sys-apps/which sys-freebsd/freebsd-ubin )
+ latex? ( >=app-text/passivetex-1.25 >=dev-tex/xmltex-1.9-r2 )"
+# We only depend on flex when we patch the imput lexer.
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog FAQ NEWS README THANKS"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.0.22-format_fo_passivetex_check.patch
+}
+
+src_configure() {
+ # We don't want the script to detect /bin/sh if it is bash.
+ export ac_cv_path_BASH=/bin/bash
+ has_version sys-apps/util-linux || export GETOPT=getopt-long
+ econf
+}