summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-09-14 16:43:29 -0400
committerMike Gilbert <floppym@gentoo.org>2023-09-14 16:45:31 -0400
commit6545573120c2238469c76b383358f507bfab6e58 (patch)
tree4443fc85193310f3358bd09477ee729731234fed /app-text/xmlto
parentdev-qt/qtwebengine: note that libva is dlopen (diff)
downloadgentoo-6545573120c2238469c76b383358f507bfab6e58.tar.gz
gentoo-6545573120c2238469c76b383358f507bfab6e58.tar.bz2
gentoo-6545573120c2238469c76b383358f507bfab6e58.zip
app-text/xmlto: pass BASH=/bin/bash to configure
This ensures the same xmlto script can be used on merged-usr and split-usr systems. Closes: https://bugs.gentoo.org/912286 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-text/xmlto')
-rw-r--r--app-text/xmlto/xmlto-0.0.28-r11.ebuild (renamed from app-text/xmlto/xmlto-0.0.28-r10.ebuild)10
1 files changed, 7 insertions, 3 deletions
diff --git a/app-text/xmlto/xmlto-0.0.28-r10.ebuild b/app-text/xmlto/xmlto-0.0.28-r11.ebuild
index 547cd6787bf8..bf44cdb5d846 100644
--- a/app-text/xmlto/xmlto-0.0.28-r10.ebuild
+++ b/app-text/xmlto/xmlto-0.0.28-r11.ebuild
@@ -15,6 +15,7 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv
IUSE="latex text"
RDEPEND="
+ app-shells/bash:0
app-text/docbook-xsl-stylesheets
app-text/docbook-xml-dtd:4.2
dev-libs/libxslt
@@ -48,9 +49,12 @@ src_prepare() {
}
src_configure() {
- # We don't want the script to detect /bin/sh if it is bash.
- export ac_cv_path_BASH="${BASH}"
has_version sys-apps/util-linux || export GETOPT=getopt-long
- econf
+ local args=(
+ # Ensure we always get a #!/bin/bash shebang in xmlto, bug 912286
+ BASH="${EPREFIX}/bin/bash"
+ )
+
+ econf "${args[@]}"
}