summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/zathura-djvu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/zathura-djvu')
-rw-r--r--app-text/zathura-djvu/Manifest2
-rw-r--r--app-text/zathura-djvu/metadata.xml25
-rw-r--r--app-text/zathura-djvu/zathura-djvu-0.2.3.ebuild50
-rw-r--r--app-text/zathura-djvu/zathura-djvu-0.2.4.ebuild50
-rw-r--r--app-text/zathura-djvu/zathura-djvu-9999.ebuild50
5 files changed, 177 insertions, 0 deletions
diff --git a/app-text/zathura-djvu/Manifest b/app-text/zathura-djvu/Manifest
new file mode 100644
index 000000000000..8b4566f38662
--- /dev/null
+++ b/app-text/zathura-djvu/Manifest
@@ -0,0 +1,2 @@
+DIST zathura-djvu-0.2.3.tar.gz 11181 SHA256 c16e82d525012b788fd01c4189df93708fcffffb7dd34ca09db55005d644ed89 SHA512 6fd9c1d367d02402bc5eaedd853ed0d37aee61a682772c3c2dd543d98c03d85b32cd2b4af4b7f7a6390e97206aa881ebd6df9783e7abf4222352fb4d57de4850 WHIRLPOOL 447aee58bf3c0e9baed6d9d60505245777fd38be8bb2ae4c2f387a98afe334a01cd870995884f99d073904ba6812120c6660d88864bc3d38798d94e1c7d9cd76
+DIST zathura-djvu-0.2.4.tar.gz 11197 SHA256 ac10b8c07fd9f58281225e1a4cb026634cd03bf6b549eaceeea02f99ab5334bc SHA512 192df545b686259089342044ab682c2517f8e377667a9d44f6f416e1ac7fb7b2e45fa22d34004583c6081650a15d2becb350296a39a647a8dcd2ccc7ef1066d8 WHIRLPOOL ca0cf5570ee5529233110b7db1c29e5572ba321b7dbe59a4632ce23861cb15e0b6e85118bd5159c94a7e5d715c10bafc856a4eb4070413eb66601513eaf26542
diff --git a/app-text/zathura-djvu/metadata.xml b/app-text/zathura-djvu/metadata.xml
new file mode 100644
index 000000000000..e21ab424480f
--- /dev/null
+++ b/app-text/zathura-djvu/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mlq@pwmt.org</email>
+ <name>Moritz Lipp</name>
+ </maintainer>
+ <maintainer status="active">
+ <email>sebastian+dev@ramacher.at</email>
+ <name>Sebastian Ramacher</name>
+ </maintainer>
+ <changelog>http://pwmt.org/projects/zathura/download/</changelog>
+ <doc lang="en">http://pwmt.org/projects/zathura/</doc>
+ <bugs-to>http://bugs.pwmt.org/</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/zathura-djvu/zathura-djvu-0.2.3.ebuild b/app-text/zathura-djvu/zathura-djvu-0.2.3.ebuild
new file mode 100644
index 000000000000..80b52bd81ae4
--- /dev/null
+++ b/app-text/zathura-djvu/zathura-djvu-0.2.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+[[ ${PV} == 9999* ]] && inherit git-2
+
+DESCRIPTION="DjVu plug-in for zathura"
+HOMEPAGE="http://pwmt.org/projects/zathura/"
+if ! [[ ${PV} == 9999* ]]; then
+SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
+EGIT_REPO_URI="git://git.pwmt.org/${PN}.git"
+EGIT_BRANCH="develop"
+
+LICENSE="ZLIB"
+SLOT="0"
+if ! [[ ${PV} == 9999* ]]; then
+KEYWORDS="amd64 arm x86"
+else
+KEYWORDS=""
+fi
+IUSE=""
+
+RDEPEND=">=app-text/djvu-3.5.24-r1:=
+ >=app-text/zathura-0.2.7
+ dev-libs/glib:2=
+ x11-libs/cairo:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ myzathuraconf=(
+ CC="$(tc-getCC)"
+ LD="$(tc-getLD)"
+ VERBOSE=1
+ DESTDIR="${D}"
+ )
+}
+
+src_compile() {
+ emake "${myzathuraconf[@]}"
+}
+
+src_install() {
+ emake "${myzathuraconf[@]}" install
+ dodoc AUTHORS
+}
diff --git a/app-text/zathura-djvu/zathura-djvu-0.2.4.ebuild b/app-text/zathura-djvu/zathura-djvu-0.2.4.ebuild
new file mode 100644
index 000000000000..a31e9ddb9fb7
--- /dev/null
+++ b/app-text/zathura-djvu/zathura-djvu-0.2.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+[[ ${PV} == 9999* ]] && inherit git-2
+
+DESCRIPTION="DjVu plug-in for zathura"
+HOMEPAGE="http://pwmt.org/projects/zathura/"
+if ! [[ ${PV} == 9999* ]]; then
+SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
+EGIT_REPO_URI="git://git.pwmt.org/${PN}.git"
+EGIT_BRANCH="develop"
+
+LICENSE="ZLIB"
+SLOT="0"
+if ! [[ ${PV} == 9999* ]]; then
+KEYWORDS="~amd64 ~arm ~x86"
+else
+KEYWORDS=""
+fi
+IUSE=""
+
+RDEPEND=">=app-text/djvu-3.5.24-r1:=
+ >=app-text/zathura-0.3.1
+ dev-libs/glib:2=
+ x11-libs/cairo:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ myzathuraconf=(
+ CC="$(tc-getCC)"
+ LD="$(tc-getLD)"
+ VERBOSE=1
+ DESTDIR="${D}"
+ )
+}
+
+src_compile() {
+ emake "${myzathuraconf[@]}"
+}
+
+src_install() {
+ emake "${myzathuraconf[@]}" install
+ dodoc AUTHORS
+}
diff --git a/app-text/zathura-djvu/zathura-djvu-9999.ebuild b/app-text/zathura-djvu/zathura-djvu-9999.ebuild
new file mode 100644
index 000000000000..a31e9ddb9fb7
--- /dev/null
+++ b/app-text/zathura-djvu/zathura-djvu-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+[[ ${PV} == 9999* ]] && inherit git-2
+
+DESCRIPTION="DjVu plug-in for zathura"
+HOMEPAGE="http://pwmt.org/projects/zathura/"
+if ! [[ ${PV} == 9999* ]]; then
+SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
+EGIT_REPO_URI="git://git.pwmt.org/${PN}.git"
+EGIT_BRANCH="develop"
+
+LICENSE="ZLIB"
+SLOT="0"
+if ! [[ ${PV} == 9999* ]]; then
+KEYWORDS="~amd64 ~arm ~x86"
+else
+KEYWORDS=""
+fi
+IUSE=""
+
+RDEPEND=">=app-text/djvu-3.5.24-r1:=
+ >=app-text/zathura-0.3.1
+ dev-libs/glib:2=
+ x11-libs/cairo:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ myzathuraconf=(
+ CC="$(tc-getCC)"
+ LD="$(tc-getLD)"
+ VERBOSE=1
+ DESTDIR="${D}"
+ )
+}
+
+src_compile() {
+ emake "${myzathuraconf[@]}"
+}
+
+src_install() {
+ emake "${myzathuraconf[@]}" install
+ dodoc AUTHORS
+}