summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2024-07-07 01:33:43 +0200
committerSebastian Pipping <sping@gentoo.org>2024-07-07 01:56:37 +0200
commit0e9f84a2caa1eb76c7210df5082c3929a87b2ffb (patch)
tree20b362ff15ada800de461b81116acff68a0d5a15 /app-text
parentnet-misc/openssh: sshd.service: set Type=notify-reload (diff)
downloadgentoo-0e9f84a2caa1eb76c7210df5082c3929a87b2ffb.tar.gz
gentoo-0e9f84a2caa1eb76c7210df5082c3929a87b2ffb.tar.bz2
gentoo-0e9f84a2caa1eb76c7210df5082c3929a87b2ffb.zip
app-text/nuspell: 5.1.6
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/nuspell/Manifest1
-rw-r--r--app-text/nuspell/nuspell-5.1.6.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/nuspell/Manifest b/app-text/nuspell/Manifest
index 71de41a24016..445bd47c9980 100644
--- a/app-text/nuspell/Manifest
+++ b/app-text/nuspell/Manifest
@@ -1,2 +1,3 @@
DIST nuspell-5.1.3.tar.gz 371496 BLAKE2B 7a4aa05b01bd085e0612cf681783cfa2314a3b775c283f7e25c19d6afbb5af74c7ea2ffe149c68ca422383c24bd043e4b5e6b0895a0acd7c376e3d39f253a867 SHA512 72c868f734848be79c7cfb0502298626307213e4f3f422f8e9ee7dac24cb3d79ea55d04ef0443e7107bb11eb545c79a15a8aea8cb056dc2805c23bd5e3292562
DIST nuspell-5.1.4.tar.gz 371512 BLAKE2B c1c05cc113cf7a6a4b77671f4fe372b2131a6cbcb328d76517bcbb45863e1fd0f27d76597193cae3a5c686d8e0b480fc831e0aa8dbcbf9f9b65420200a13d444 SHA512 f4119b3fe5944be8f5bc35ccff8d7a93b0f4fa9f129bc97a7b96879a11b5b35bd714b41dd209267417e94c5fed45fd3a74b349f94424f4b90bde07d9694d1d7d
+DIST nuspell-5.1.6.tar.gz 373260 BLAKE2B 978f1055c4e8f68a1e7e712b98af11b5f9a4be3b42044d7d31733cf30d301145da501da95168e1c96518bba6e0f2d525a6929d5fa81f350828158e6db7dad147 SHA512 ab6d9394a55d9a2a347ccae47aeef6a96af70f421ad6ea8f7ac7fde2052790f37fb1c7ec3112daac7600d193430a560cb1915ab6557c9353717f65cb32f13ab8
diff --git a/app-text/nuspell/nuspell-5.1.6.ebuild b/app-text/nuspell/nuspell-5.1.6.ebuild
new file mode 100644
index 000000000000..58d1d8ac4075
--- /dev/null
+++ b/app-text/nuspell/nuspell-5.1.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Spell checker library and CLI for complex natural languages"
+HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
+SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/5" # due to libnuspell.so.5
+KEYWORDS="~amd64 ~loong ~riscv ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/icu-60"
+DEPEND="${RDEPEND}
+ doc? ( virtual/pandoc )
+ test? ( >=dev-cpp/catch-3.1.1:0 )
+ "
+
+DOCS=( CHANGELOG.md )
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ if ! use test ; then
+ rm -R external/hunspell/ || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCS=$(usex doc)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo 'Nuspell needs language packs and/or dictionaries to be of use'
+ einfo 'e.g. package app-dicts/myspell-en or one of its siblings.'
+ einfo
+ einfo 'Besides MySpell dictionaries, for other options please'
+ einfo 'see https://nuspell.github.io/#languages-and-users .'
+ einfo
+}