summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-18 18:12:48 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-18 18:19:24 -0400
commit637395ff1a929c8fd54cae0239a7d85f5d4555ff (patch)
treeb169fa6fdd4a95a02104abbb650aa45bd20c69b3 /app-text
parentapp-editors/gedit: Version bump to 40.1 (diff)
downloadgentoo-637395ff1a929c8fd54cae0239a7d85f5d4555ff.tar.gz
gentoo-637395ff1a929c8fd54cae0239a7d85f5d4555ff.tar.bz2
gentoo-637395ff1a929c8fd54cae0239a7d85f5d4555ff.zip
app-text/evince: Version bump to 40.1
Closes: https://bugs.gentoo.org/782661 Closes: https://bugs.gentoo.org/782664 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/evince/Manifest1
-rw-r--r--app-text/evince/evince-40.1.ebuild130
2 files changed, 131 insertions, 0 deletions
diff --git a/app-text/evince/Manifest b/app-text/evince/Manifest
index 595f68e52782..62593c22dc85 100644
--- a/app-text/evince/Manifest
+++ b/app-text/evince/Manifest
@@ -1,2 +1,3 @@
DIST evince-3.36.10.tar.xz 2430584 BLAKE2B 7c8b5e3dec7168f4ab6976022bb85041fd8cc9f55b8c032bbf03cf492d243dc49f00d6913c1f2f09498c1b4091b4be126a9367dd3ed235635e9d08e6a9ae5a0d SHA512 2a17fc1fbd18e2685c254194d0e195ec0c6126f37212ae64297fb06f30f2e07f926cb768affb4d5c9c407c4dfc43db3578ffd244c9a6e121d1d3c9b5e653b4d2
DIST evince-40.0.tar.xz 2928668 BLAKE2B 852c532b595f50e849893670b536b5b8c25f0407a719cbe659faa3f72b51f43a0471c3df9197fa5bd11735c14e0779d8cf28a88cd79aabec4dffa797443b9819 SHA512 995693e4a6e1a3bb31e1d4f3538dc53519102a5a6afa58ba61454a1e2ca582df26bd368876210fce6fab8ff4e218305644fa7a7a88c99e1a1ca5bda8d8f1ece2
+DIST evince-40.1.tar.xz 2928924 BLAKE2B e9376c186da9fed132b820b2e9a1ef6bb0997f22abca3d7b271691291ea4870132b48075ada5a992e056193e6af51bdf95e6bbdac79c789475fb985d692f9ccc SHA512 c688ee962cfff8b024b572161bae689d25b5b566ac623abeff38b4b8e6e541ce343023ed2c1ba0df1f65d6ec9a631aac3a748c940db556dbb89ab45ac565147d
diff --git a/app-text/evince/evince-40.1.ebuild b/app-text/evince/evince-40.1.ebuild
new file mode 100644
index 000000000000..05e5b8fd667b
--- /dev/null
+++ b/app-text/evince/evince-40.1.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson systemd xdg
+
+DESCRIPTION="Simple document viewer for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evince"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+# subslot = evd3.(suffix of libevdocument3)-evv3.(suffix of libevview3)
+SLOT="0/evd3.4-evv3.3"
+IUSE="cups djvu dvi gstreamer gnome gnome-keyring gtk-doc +introspection nautilus nsplugin postscript spell t1lib tiff xps"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+
+# atk used in libview
+# bundles unarr
+DEPEND="
+ dev-libs/atk
+ >=dev-libs/glib-2.44.0:2
+ >=gui-libs/libhandy-1.0:1=
+ >=dev-libs/libxml2-2.5:2
+ sys-libs/zlib:=
+ >=x11-libs/gdk-pixbuf-2.40:2
+ >=x11-libs/gtk+-3.22.0:3[cups?,introspection?]
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/cairo-1.10:=
+ >=app-text/poppler-0.76.0[cairo]
+ >=app-arch/libarchive-3.2.0
+ djvu? ( >=app-text/djvu-3.5.22:= )
+ dvi? (
+ >=app-text/libspectre-0.2:=
+ dev-libs/kpathsea:=
+ t1lib? ( >=media-libs/t1lib-5:= ) )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0 )
+ gnome? ( gnome-base/gnome-desktop:3= )
+ gnome-keyring? ( >=app-crypt/libsecret-0.5 )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+ nautilus? ( >=gnome-base/nautilus-3.28.0 )
+ postscript? ( >=app-text/libspectre-0.2:= )
+ spell? ( >=app-text/gspell-1.6.0:= )
+ tiff? ( >=media-libs/tiff-3.6:0= )
+ xps? ( >=app-text/libgxps-0.2.1:= )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gvfs
+ gnome-base/librsvg
+ || (
+ >=x11-themes/adwaita-icon-theme-2.17.1
+ >=x11-themes/hicolor-icon-theme-0.10
+ )
+"
+BDEPEND="
+ gtk-doc? ( >=dev-util/gtk-doc-1.33 )
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/40.0-internal-synctex.patch
+)
+
+src_prepare() {
+ default
+
+ # Do not depend on adwaita-icon-theme, bug #326855, #391859
+ # https://gitlab.freedesktop.org/xdg/default-icon-theme/issues/7
+ sed -i '/adwaita_icon_theme_dep/d' meson.build shell/meson.build || die
+
+ # https://gitlab.gnome.org/GNOME/evince/-/merge_requests/336
+ sed -i -e 's:T1_initLib:T1_InitLib:' meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dplatform=gnome
+
+ -Dviewer=true
+ -Dpreviewer=false
+ -Dthumbnailer=true
+ $(meson_use nsplugin browser_plugin)
+ $(meson_use nautilus)
+
+ -Dcomics=enabled
+ $(meson_feature djvu)
+ $(meson_feature dvi)
+ -Dpdf=enabled
+ $(meson_feature postscript ps)
+ $(meson_feature tiff)
+ $(meson_feature xps)
+
+ $(meson_use gtk-doc gtk_doc)
+ -Duser_doc=true
+ $(meson_use introspection)
+ -Ddbus=true
+ $(meson_feature gnome-keyring keyring)
+ $(meson_feature cups gtk_unix_print)
+ $(meson_feature gnome thumbnail_cache)
+ $(meson_feature gstreamer multimedia)
+ $(meson_feature spell gspell)
+
+ $(meson_feature t1lib)
+
+ -Dbrowser_plugin_dir="${EPREFIX}/usr/$(get_libdir)/nsbrowser/plugins"
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+}
+
+src_test() {
+ meson_src_test
+}
+
+src_install() {
+ meson_src_install
+}