summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoão Santos <joaompssantos@gmail.com>2018-08-29 13:12:54 +0100
committerMichał Górny <mgorny@gentoo.org>2018-09-16 21:39:17 +0200
commitb3b4a8799df79f75c725fb9df142766976c80a94 (patch)
tree3defa50f1431be118f1aca3b03eaafbde123fd7d /app-text
parentapp-text/master-pdf-editor: removed 5.1.00 as sources are no longer (diff)
downloadgentoo-b3b4a8799df79f75c725fb9df142766976c80a94.tar.gz
gentoo-b3b4a8799df79f75c725fb9df142766976c80a94.tar.bz2
gentoo-b3b4a8799df79f75c725fb9df142766976c80a94.zip
app-text/master-pdf-editor: version bump to 5.1.36
Closes: https://github.com/gentoo/gentoo/pull/9775
Diffstat (limited to 'app-text')
-rw-r--r--app-text/master-pdf-editor/Manifest1
-rw-r--r--app-text/master-pdf-editor/master-pdf-editor-5.1.30.ebuild2
-rw-r--r--app-text/master-pdf-editor/master-pdf-editor-5.1.36.ebuild51
3 files changed, 53 insertions, 1 deletions
diff --git a/app-text/master-pdf-editor/Manifest b/app-text/master-pdf-editor/Manifest
index 60e22cb83bf0..62b7c200a7e7 100644
--- a/app-text/master-pdf-editor/Manifest
+++ b/app-text/master-pdf-editor/Manifest
@@ -1 +1,2 @@
DIST master-pdf-editor-5.1.30_qt5.amd64.tar.gz 16150271 BLAKE2B dfbdacb6df75d268c57cc5d7f6c949c796abecd09394a80694dfc05b5e666c4e836f636b5af6a17a309625ed243e88c1871347e8f7162b6e3f8c47fc27d83e26 SHA512 3cc0a85e9518e75581cfdc05ac8dbdbd534fa11b4f4cfb490a0e9b411b84c073d52e9a5a3aa620507c88117cc04e033f5e860e335b37aef49eec95f2352e9b21
+DIST master-pdf-editor-5.1.36_qt5.amd64.tar.gz 16149439 BLAKE2B 882f399bfb5cf7b2a39c8174f541a1124953df5bc3bf5ded27bba1eec3ebc966e1b5c0174219759995d939ff203426a2004be61989fa7d062c26dc64320769b5 SHA512 934e9d856476e412a7b40858365e843a8350f638b48a9b593faeab12cd9032243042fd11929e826a294a29ab3810110c40fdd07f56e8c5d0fb6fa2f957a36c21
diff --git a/app-text/master-pdf-editor/master-pdf-editor-5.1.30.ebuild b/app-text/master-pdf-editor/master-pdf-editor-5.1.30.ebuild
index 1ed334d5153a..05c37155037b 100644
--- a/app-text/master-pdf-editor/master-pdf-editor-5.1.30.ebuild
+++ b/app-text/master-pdf-editor/master-pdf-editor-5.1.30.ebuild
@@ -34,8 +34,8 @@ src_install() {
exeinto /opt/${PN}
doexe masterpdfeditor5
-
dosym ../${PN}/masterpdfeditor5 /opt/bin/masterpdfeditor5
+
make_desktop_entry "masterpdfeditor5 %f" \
"Master PDF Editor ${PV}" /opt/${PN}/masterpdfeditor5.png \
"Office;Graphics;Viewer" \
diff --git a/app-text/master-pdf-editor/master-pdf-editor-5.1.36.ebuild b/app-text/master-pdf-editor/master-pdf-editor-5.1.36.ebuild
new file mode 100644
index 000000000000..05c37155037b
--- /dev/null
+++ b/app-text/master-pdf-editor/master-pdf-editor-5.1.36.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xdg-utils desktop
+
+DESCRIPTION="A complete solution for viewing and editing PDF files"
+HOMEPAGE="https://code-industry.net/free-pdf-editor/"
+SRC_URI="https://code-industry.net/public/${P}_qt5.amd64.tar.gz"
+
+LICENSE="master-pdf-editor"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+COMMON_DEPEND="
+ >=media-gfx/sane-backends-1.0
+ >=dev-qt/qtsvg-5.4.1:5
+ >=dev-qt/qtnetwork-5.4.1:5
+ >=dev-qt/qtgui-5.4.1:5
+ >=dev-qt/qtprintsupport-5.4.1:5
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+QA_PREBUILT="/opt/${PN}/masterpdfeditor5"
+
+S="${WORKDIR}/${PN}-${PV%%.*}"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r fonts lang stamps templates masterpdfeditor5.png
+
+ exeinto /opt/${PN}
+ doexe masterpdfeditor5
+ dosym ../${PN}/masterpdfeditor5 /opt/bin/masterpdfeditor5
+
+ make_desktop_entry "masterpdfeditor5 %f" \
+ "Master PDF Editor ${PV}" /opt/${PN}/masterpdfeditor5.png \
+ "Office;Graphics;Viewer" \
+ "MimeType=application/pdf;application/x-bzpdf;application/x-gzpdf;\nTerminal=false"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}