summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/surround
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/surround')
-rw-r--r--app-vim/surround/Manifest2
-rw-r--r--app-vim/surround/metadata.xml5
-rw-r--r--app-vim/surround/surround-2.0.ebuild15
-rw-r--r--app-vim/surround/surround-2.1.ebuild14
4 files changed, 36 insertions, 0 deletions
diff --git a/app-vim/surround/Manifest b/app-vim/surround/Manifest
new file mode 100644
index 000000000000..113d3948e99a
--- /dev/null
+++ b/app-vim/surround/Manifest
@@ -0,0 +1,2 @@
+DIST surround-2.0.tar.bz2 8285 SHA256 4203e827030ebcb782eb2c166b05888036ed060e1a2f2415878a1230041a495c SHA512 0e9eb05865300ef089217edac474908d0e73a2343069b9806523164a98506cff02a8f2b09425edf9c574f7b6173f57e66cc1017195e1d5aba57e25ac5afe087a WHIRLPOOL 5ba9a1ff43c5578289d2021ef1456d00db2b4c7a37371cf9da640d00fe82b254ff39cfe5763d05f757d67df343fd12c30a6da621dac00595fbafe6283b745de5
+DIST surround-2.1.tar.bz2 8441 SHA256 0bc6d088294e608fc0fee92af9aebea933b4e3aff441011786d19a11809b45dc SHA512 2b4283f77dac468ab91cdc941ac2dd5a2b99a35c23d6ffdc1e1c819a04bf45ecb934c5a111898ed45539a02d1f1ce6c702da80685f609944cbec9bdd25a1e22e WHIRLPOOL f21035d8829c4a41c47d339812769ec11337ae4125622058b1795135d0a77b81294385bd9149b410530407961c6f792dc9a83e8d8541f6d8683bf204a60b2dcb
diff --git a/app-vim/surround/metadata.xml b/app-vim/surround/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/surround/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>
diff --git a/app-vim/surround/surround-2.0.ebuild b/app-vim/surround/surround-2.0.ebuild
new file mode 100644
index 000000000000..0e9fcfce8c64
--- /dev/null
+++ b/app-vim/surround/surround-2.0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Delete/change/add parentheses/quotes/XML-tags/much more"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1697"
+LICENSE="vim"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}"
diff --git a/app-vim/surround/surround-2.1.ebuild b/app-vim/surround/surround-2.1.ebuild
new file mode 100644
index 000000000000..214b875bff90
--- /dev/null
+++ b/app-vim/surround/surround-2.1.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Delete/change/add parentheses/quotes/XML-tags/much more"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1697"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"