summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-09-24 00:25:39 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-09-24 00:25:57 +0200
commit79f467450adbe10133eb2706cf7ba27f4057a236 (patch)
tree3cb6e481c0648ca058cdf67297042216578bac5c /app-vim
parentwww-plugins/chrome-binary-plugins: automated update (diff)
downloadgentoo-79f467450adbe10133eb2706cf7ba27f4057a236.tar.gz
gentoo-79f467450adbe10133eb2706cf7ba27f4057a236.tar.bz2
gentoo-79f467450adbe10133eb2706cf7ba27f4057a236.zip
app-vim/perlomni: add perlomni to the tree.
perl-completion is a plugin which supports basic Perl completion for vim. Package-Manager: portage-2.2.28
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/perlomni/Manifest1
-rw-r--r--app-vim/perlomni/metadata.xml11
-rw-r--r--app-vim/perlomni/perlomni-2.5.ebuild28
3 files changed, 40 insertions, 0 deletions
diff --git a/app-vim/perlomni/Manifest b/app-vim/perlomni/Manifest
new file mode 100644
index 000000000000..fdd2bcd2b6d0
--- /dev/null
+++ b/app-vim/perlomni/Manifest
@@ -0,0 +1 @@
+DIST perlomni-2.5.zip 26871 SHA256 b13f8ed41ecdfa779875c48ac2df1241272ac03cef53271054dc6e9c0b011288 SHA512 aeb4bb6efef859145a942271ac4e08c99af3aed45024ca2d5affe2e72c356fa4e8f9cef78ff8a1796426ec9d2339ea2b83f07b224a1b4b98598aec5f6f45b0d7 WHIRLPOOL a8f62ff6c7a0535d0177bea205206505ad3d578c50a2ce8880fa2cfb32ba3e8fa6f750908ec846ac0a7b2af546c34043676c8747b11504487e178f93ecbc4089
diff --git a/app-vim/perlomni/metadata.xml b/app-vim/perlomni/metadata.xml
new file mode 100644
index 000000000000..6c8987e6f46f
--- /dev/null
+++ b/app-vim/perlomni/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/perlomni/perlomni-2.5.ebuild b/app-vim/perlomni/perlomni-2.5.ebuild
new file mode 100644
index 000000000000..28b0746ba030
--- /dev/null
+++ b/app-vim/perlomni/perlomni-2.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Perl omni completion"
+HOMEPAGE="https://github.com/c9s/perlomni.vim"
+SRC_URI="https://github.com/c9s/${PN}.vim/archive/v${PV}.zip -> ${P}.zip"
+LICENSE="vim.org"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ app-arch/unzip
+ dev-lang/perl"
+
+S="${WORKDIR}/${PN}.vim-${PV}"
+
+src_prepare() {
+ default
+ rm -v Makefile config.mk README.mkd README.mkd.old win32-install.bat TODO || die
+}
+
+src_compile() {
+ :;
+}