summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Novomesky <dnovomesky@gmail.com>2022-03-10 12:37:39 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-03-24 14:46:39 +0200
commitfb8fa4aa1e945ec66a7588b6a89f091cadfd788e (patch)
tree9fa37b8eb45a708182f1e25677f46ddce2988158 /dev-cpp/highway
parentmedia-sound/denemo: add few missing deps to 2.6.0 (diff)
downloadgentoo-fb8fa4aa1e945ec66a7588b6a89f091cadfd788e.tar.gz
gentoo-fb8fa4aa1e945ec66a7588b6a89f091cadfd788e.tar.bz2
gentoo-fb8fa4aa1e945ec66a7588b6a89f091cadfd788e.zip
dev-cpp/highway: new package, moved from ::guru
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Daniel Novomesky <dnovomesky@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-cpp/highway')
-rw-r--r--dev-cpp/highway/Manifest1
-rw-r--r--dev-cpp/highway/highway-0.16.0.ebuild37
-rw-r--r--dev-cpp/highway/highway-9999.ebuild37
-rw-r--r--dev-cpp/highway/metadata.xml16
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-cpp/highway/Manifest b/dev-cpp/highway/Manifest
new file mode 100644
index 000000000000..7510c7106e76
--- /dev/null
+++ b/dev-cpp/highway/Manifest
@@ -0,0 +1 @@
+DIST highway-0.16.0.tar.gz 1639388 BLAKE2B 660b0079b25a12a2e982b4ba16147b923d167989a7dc1c0cb65ebe5219577f2f02c8774a554fd3fe9e1c10ef7b1cf5db747500bd8acf454e26952722f7b5ac9e SHA512 c08e66f43d9d0b307737b016cfa6c3d3a1df9bd528de435d193388104f34c264866c5ff0da633fc0a6f8c50f21df1ac653e9dd3f6fbfaf227d636411ac14cd47
diff --git a/dev-cpp/highway/highway-0.16.0.ebuild b/dev-cpp/highway/highway-0.16.0.ebuild
new file mode 100644
index 000000000000..4371d5e0bc03
--- /dev/null
+++ b/dev-cpp/highway/highway-0.16.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
+HOMEPAGE="https://github.com/google/highway"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/google/highway.git"
+else
+ SRC_URI="https://github.com/google/highway/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? ( dev-cpp/gtest[${MULTILIB_USEDEP}] )"
+
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DHWY_WARNINGS_ARE_ERRORS=OFF
+ )
+
+ use test && mycmakeargs+=( "-DHWY_SYSTEM_GTEST=ON" )
+
+ cmake_src_configure
+}
diff --git a/dev-cpp/highway/highway-9999.ebuild b/dev-cpp/highway/highway-9999.ebuild
new file mode 100644
index 000000000000..4371d5e0bc03
--- /dev/null
+++ b/dev-cpp/highway/highway-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
+HOMEPAGE="https://github.com/google/highway"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/google/highway.git"
+else
+ SRC_URI="https://github.com/google/highway/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? ( dev-cpp/gtest[${MULTILIB_USEDEP}] )"
+
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DHWY_WARNINGS_ARE_ERRORS=OFF
+ )
+
+ use test && mycmakeargs+=( "-DHWY_SYSTEM_GTEST=ON" )
+
+ cmake_src_configure
+}
diff --git a/dev-cpp/highway/metadata.xml b/dev-cpp/highway/metadata.xml
new file mode 100644
index 000000000000..717dcaf45afe
--- /dev/null
+++ b/dev-cpp/highway/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>dnovomesky@gmail.com</email>
+ <name>Daniel Novomesky</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Highway is a C++ library for SIMD (Single Instruction, Multiple Data),
+ i.e. applying the same operation to multiple 'lanes' using a single CPU instruction.
+ </longdescription>
+</pkgmetadata>