summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-09-02 09:30:38 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-09-02 10:01:09 +0100
commit17210d6df606eae8555385843976e233aab33ac1 (patch)
treebf5b85f6fbc77ac4fc824760484c37556bbfbfe7 /dev-cpp/sdbus-c++
parentgui-wm/gamescope: Bump to 3.12.5, drop old 3.12.3 (diff)
downloadgentoo-17210d6df606eae8555385843976e233aab33ac1.tar.gz
gentoo-17210d6df606eae8555385843976e233aab33ac1.tar.bz2
gentoo-17210d6df606eae8555385843976e233aab33ac1.zip
dev-cpp/sdbus-c++: Bump to 1.3.0, drop old 1.2.0-r1
It now works with elogind! Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-cpp/sdbus-c++')
-rw-r--r--dev-cpp/sdbus-c++/Manifest2
-rw-r--r--dev-cpp/sdbus-c++/files/0001-fix-integration-tests-for-libsystemd-v251.patch39
-rw-r--r--dev-cpp/sdbus-c++/sdbus-c++-1.2.0-r1.ebuild149
-rw-r--r--dev-cpp/sdbus-c++/sdbus-c++-1.3.0.ebuild73
4 files changed, 74 insertions, 189 deletions
diff --git a/dev-cpp/sdbus-c++/Manifest b/dev-cpp/sdbus-c++/Manifest
index dc68d12bda1f..dce128efad4d 100644
--- a/dev-cpp/sdbus-c++/Manifest
+++ b/dev-cpp/sdbus-c++/Manifest
@@ -1,4 +1,4 @@
DIST sdbus-c++-0.9.0.tar.gz 198979 BLAKE2B 31cda7ce97aad05f93a015ca0f8bd93aa095f6abb6bc513343767c7221d2aeacc96ee2b6a1b0ecf50850f17506fc97aa3a9fead0332687d57bdbddf806502826 SHA512 8695d3efac5654cb28998cdd69c16f251654b2c95e0dc2a2f5a4b01b24dae7b04e1a1f2e9bc9fb96b99f099dd4a130ca980cb672f74829565fd0d48162a581c5
-DIST sdbus-c++-1.2.0.tar.gz 205798 BLAKE2B da040acb49f5294665b09df97c171eac38f7c6ce5e86093b45b896c4b216afc9b45870395404ffb8e7c32ac8b98f6c795fb528691b344587545e5ae27d4423d6 SHA512 dab2c4d9a5ea6d626672a5a6ee6f3490c60c6fdd160769801a4d6b4cf3df4983fad57ff0230132a5d637ec78a55993200ce217fa89461016e101865cc2777d7d
+DIST sdbus-c++-1.3.0.tar.gz 217150 BLAKE2B aa9a902cdff6a6f2268cfe04b45105ab08ee4b3a257db10af63f8224a9932e28c5f755879c866274722a2087a59c0a22dc0616ac5d696229daeaa965a156e220 SHA512 8f4cb9ae88b1ec0db0bcc27e131fcb9ad8a8bc88e39721b3b73f63e057bae4cd36619894e25114ccddb1a8e6c21db2f80adcabb3263ff5d8b34b72af7563afe2
DIST systemd-musl-patches-252.4.tar.gz 25053 BLAKE2B 1d75f85ea0c48c788e9199e2d919bac90edce16a9788a349332cf308c32fb9510ac2883f8e09f21e7f37fbac2e557dc39cdf44dcd7a986587c40dedd2d1b5df5 SHA512 1dc8e220eae1869eb4bb50f9c701392542b053099cf9b6bde13f12a2d26fa29984819a8b4ce1b6c57e38a71f86324469a87cf9e22abe0f6d67ac3e84c6b9a3ba
DIST systemd-stable-252.6.tar.gz 11823064 BLAKE2B 0c260685c929b5271efba13d6ba84bc99211ead7d080b5e9b0d68428fe46a8a8a556b140787dd21f7b19e1454a78f15bf407038b3dc02a4d3db2336f3d881255 SHA512 948cb3f7c6a4bbc2bcc3ebe4f36afac304c9d694dadac7e363bbdb79f111eb5d69fd501433ba6719d79d833206a019cb40a37b16a92c8d22acbdd9736cdbdd37
diff --git a/dev-cpp/sdbus-c++/files/0001-fix-integration-tests-for-libsystemd-v251.patch b/dev-cpp/sdbus-c++/files/0001-fix-integration-tests-for-libsystemd-v251.patch
deleted file mode 100644
index 93767dc94be7..000000000000
--- a/dev-cpp/sdbus-c++/files/0001-fix-integration-tests-for-libsystemd-v251.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From c812d03bc726aafc90f996073bfc327bb0ae230d Mon Sep 17 00:00:00 2001
-From: Stanislav Angelovic <stanislav.angelovic@siemens.com>
-Date: Mon, 2 Jan 2023 15:05:57 +0100
-Subject: [PATCH] fix: integration tests for libsystemd v251
-
-diff --git a/tests/integrationtests/DBusStandardInterfacesTests.cpp b/tests/integrationtests/DBusStandardInterfacesTests.cpp
-index a291be3..6381587 100644
---- a/tests/integrationtests/DBusStandardInterfacesTests.cpp
-+++ b/tests/integrationtests/DBusStandardInterfacesTests.cpp
-@@ -201,7 +201,13 @@ TEST_F(SdbusTestObject, EmitsInterfacesAddedSignalForAllObjectInterfaces)
- , const std::map<std::string, std::map<std::string, sdbus::Variant>>& interfacesAndProperties )
- {
- EXPECT_THAT(objectPath, Eq(OBJECT_PATH));
-+#if LIBSYSTEMD_VERSION<=250
- EXPECT_THAT(interfacesAndProperties, SizeIs(5)); // INTERFACE_NAME + 4 standard interfaces
-+#else
-+ // Since systemd v251, ObjectManager standard interface is not listed among the interfaces
-+ // if the object does not have object manager functionality explicitly enabled.
-+ EXPECT_THAT(interfacesAndProperties, SizeIs(4)); // INTERFACE_NAME + 3 standard interfaces
-+#endif
- #if LIBSYSTEMD_VERSION<=244
- // Up to sd-bus v244, all properties are added to the list, i.e. `state', `action', and `blocking' in this case.
- EXPECT_THAT(interfacesAndProperties.at(INTERFACE_NAME), SizeIs(3));
-@@ -248,7 +254,13 @@ TEST_F(SdbusTestObject, EmitsInterfacesRemovedSignalForAllObjectInterfaces)
- , const std::vector<std::string>& interfaces )
- {
- EXPECT_THAT(objectPath, Eq(OBJECT_PATH));
-+#if LIBSYSTEMD_VERSION<=250
- ASSERT_THAT(interfaces, SizeIs(5)); // INTERFACE_NAME + 4 standard interfaces
-+#else
-+ // Since systemd v251, ObjectManager standard interface is not listed among the interfaces
-+ // if the object does not have object manager functionality explicitly enabled.
-+ ASSERT_THAT(interfaces, SizeIs(4)); // INTERFACE_NAME + 3 standard interfaces
-+#endif
- signalReceived = true;
- };
-
---
-2.39.1
diff --git a/dev-cpp/sdbus-c++/sdbus-c++-1.2.0-r1.ebuild b/dev-cpp/sdbus-c++/sdbus-c++-1.2.0-r1.ebuild
deleted file mode 100644
index 56e8e1beb44e..000000000000
--- a/dev-cpp/sdbus-c++/sdbus-c++-1.2.0-r1.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-inherit python-any-r1 meson cmake flag-o-matic
-
-SDP="systemd-stable-252.6"
-MUSL_PATCHSET="systemd-musl-patches-252.4"
-
-DESCRIPTION="High-level C++ D-Bus library"
-HOMEPAGE="https://github.com/Kistler-Group/sdbus-cpp"
-SRC_URI="https://github.com/Kistler-Group/sdbus-cpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- !systemd? (
- https://github.com/systemd/${SDP%-*}/archive/v${SDP##*-}/${SDP}.tar.gz
- elibc_musl? (
- https://dev.gentoo.org/~floppym/distfiles/${MUSL_PATCHSET}.tar.gz
- https://dev.gentoo.org/~gyakovlev/distfiles/${MUSL_PATCHSET}.tar.gz
- https://dev.gentoo.org/~soap/distfiles/${MUSL_PATCHSET}.tar.gz
- )
- )"
-LICENSE="LGPL-2.1+ Nokia-Qt-LGPL-Exception-1.1" # Nothing to do with Qt but exception text is exactly the same.
-SLOT="0/1"
-KEYWORDS="~amd64"
-IUSE="doc systemd test tools"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- !systemd? ( sys-libs/libcap )
- systemd? ( >=sys-apps/systemd-236:= )
- tools? ( dev-libs/expat )
-"
-
-# util-linux is needed for libmount when building libsystemd, but sdbus-c++
-# doesn't need it when subsequently linking libsystemd statically.
-
-DEPEND="
- ${RDEPEND}
- !systemd? ( sys-apps/util-linux )
- test? ( >=dev-cpp/gtest-1.10.0 )
-"
-
-BDEPEND="
- virtual/pkgconfig
- doc? ( app-doc/doxygen[dot] )
- !systemd? (
- ${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/jinja[${PYTHON_USEDEP}]')
- )
-"
-
-python_check_deps() {
- python_has_version -b "dev-python/jinja[${PYTHON_USEDEP}]"
-}
-
-S="${WORKDIR}/sdbus-cpp-${PV}"
-SDS="${WORKDIR}/${SDP}"
-SDB="${WORKDIR}/systemd-build"
-
-PATCHES=(
- "${FILESDIR}"/0001-fix-integration-tests-for-libsystemd-v251.patch
- "${FILESDIR}"/${PN}-pc-reqs.patch
-)
-
-pkg_setup() {
- use systemd || python-any-r1_pkg_setup
-}
-
-src_prepare() {
- if ! use systemd; then
- pushd "${SDS}" || die
- use elibc_musl && eapply "${WORKDIR}/${MUSL_PATCHSET}"
- eapply "${FILESDIR}"/${PN}-static-libsystemd.patch
- popd || die
- fi
-
- cmake_src_prepare
-}
-
-src_configure() {
- if ! use systemd; then
- # Avoid redefinition of struct ethhdr.
- use elibc_musl && append-cppflags -D__UAPI_DEF_ETHHDR=0
-
- EMESON_SOURCE=${SDS} \
- BUILD_DIR=${SDB} \
- meson_src_configure \
- --prefix "${WORKDIR}" \
- --includedir "${SDP}/src" \
- -Drootlibdir="${SDB}" \
- -Dselinux=false \
- -Dstatic-libsystemd=pic \
- -Dgshadow=false \
- -Dsmack=false \
- -Dutmp=false
-
- # systemd doesn't generate the needed pkg-config file during configure.
- BUILD_DIR=${SDB} \
- meson_src_compile libsystemd.pc
-
- # Need this present otherwise CMake generates the wrong linker args.
- touch "${SDB}"/libsystemd.a || die
- fi
-
- local mycmakeargs=(
- -DBUILD_CODE_GEN=$(usex tools)
- -DBUILD_DOC=yes
- -DBUILD_DOXYGEN_DOC=$(usex doc)
- -DBUILD_LIBSYSTEMD=no
- -DBUILD_TESTS=$(usex test)
- )
-
- PKG_CONFIG_PATH=${SDB}/src/libsystemd:${PKG_CONFIG_PATH} \
- cmake_src_configure
-}
-
-src_compile() {
- if ! use systemd; then
- BUILD_DIR=${SDB} \
- meson_src_compile version.h systemd:static_library
- fi
-
- cmake_src_compile all $(usev doc)
-}
-
-src_test() {
- if ! cmp -s {"${S}"/tests/integrationtests/files,/etc/dbus-1/system.d}/org.sdbuscpp.integrationtests.conf; then
- ewarn "Not running the tests as a D-Bus configuration file has not been"
- ewarn "installed yet or has changed since. The tests can be run after"
- ewarn "the package has been merged."
- return
- elif [[ ! -S /run/dbus/system_bus_socket ]]; then
- ewarn "Not running the tests as the system-wide D-Bus daemon is unavailable."
- return
- fi
-
- cmake_src_test
-}
-
-src_install() {
- cmake_src_install
- rm -v "${ED}"/usr/share/doc/${PF}/COPYING || die
-
- if use test; then
- # Delete installed test binaries.
- rm -rv "${ED}"/opt || die
- fi
-}
diff --git a/dev-cpp/sdbus-c++/sdbus-c++-1.3.0.ebuild b/dev-cpp/sdbus-c++/sdbus-c++-1.3.0.ebuild
new file mode 100644
index 000000000000..9ea9f723b88a
--- /dev/null
+++ b/dev-cpp/sdbus-c++/sdbus-c++-1.3.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson cmake
+
+DESCRIPTION="High-level C++ D-Bus library"
+HOMEPAGE="https://github.com/Kistler-Group/sdbus-cpp"
+SRC_URI="https://github.com/Kistler-Group/sdbus-cpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1+ Nokia-Qt-LGPL-Exception-1.1" # Nothing to do with Qt but exception text is exactly the same.
+SLOT="0/1"
+KEYWORDS="~amd64"
+IUSE="doc +elogind systemd test tools"
+REQUIRED_USE="^^ ( elogind systemd )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ elogind? ( >=sys-auth/elogind-236 )
+ systemd? ( >=sys-apps/systemd-236:= )
+ tools? ( dev-libs/expat )
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( >=dev-cpp/gtest-1.10.0 )
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+"
+
+S="${WORKDIR}/sdbus-cpp-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_CODE_GEN=$(usex tools)
+ -DBUILD_DOC=yes
+ -DBUILD_DOXYGEN_DOC=$(usex doc)
+ -DBUILD_LIBSYSTEMD=no
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile all $(usev doc)
+}
+
+src_test() {
+ if ! cmp -s {"${S}"/tests/integrationtests/files,/etc/dbus-1/system.d}/org.sdbuscpp.integrationtests.conf; then
+ ewarn "Not running the tests as a D-Bus configuration file has not been"
+ ewarn "installed yet or has changed since. The tests can be run after"
+ ewarn "the package has been merged."
+ return
+ elif [[ ! -S /run/dbus/system_bus_socket ]]; then
+ ewarn "Not running the tests as the system-wide D-Bus daemon is unavailable."
+ return
+ fi
+
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+ rm -v "${ED}"/usr/share/doc/${PF}/COPYING || die
+
+ if use test; then
+ # Delete installed test binaries.
+ rm -rv "${ED}"/opt || die
+ fi
+}