summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Fröhning <misanthropos@gmx.net>2021-01-26 15:18:59 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-02-03 09:21:11 +0200
commit174c34b1f2dbb424aeb2924b6c879ed78fc230b9 (patch)
treed30da40e60b0ca96a83570c154e7769ebc1fa483 /dev-cpp/string-theory/string-theory-3.4.ebuild
parentdev-db/sqldeveloper: sort the deps like we do on 20.4.0 (diff)
downloadgentoo-174c34b1f2dbb424aeb2924b6c879ed78fc230b9.tar.gz
gentoo-174c34b1f2dbb424aeb2924b6c879ed78fc230b9.tar.bz2
gentoo-174c34b1f2dbb424aeb2924b6c879ed78fc230b9.zip
dev-cpp/string-theory: version bump to 3.4
Signed-off-by: Richard Fröhning <misanthropos@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/19228 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-cpp/string-theory/string-theory-3.4.ebuild')
-rw-r--r--dev-cpp/string-theory/string-theory-3.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-cpp/string-theory/string-theory-3.4.ebuild b/dev-cpp/string-theory/string-theory-3.4.ebuild
new file mode 100644
index 000000000000..5706dd0292ea
--- /dev/null
+++ b/dev-cpp/string-theory/string-theory-3.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A flexible modern C++ library for string manipulation and storage"
+HOMEPAGE="https://github.com/zrax/string_theory/"
+SRC_URI="https://github.com/zrax/string_theory/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/string_theory-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ # Drop -Werror from bundled gtest
+ # bug #766468
+ sed -i -e "s/-Werror//" test/gtest-1.10.0/cmake/internal_utils.cmake || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DST_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}/test" || die
+ ./st_gtests || die
+}