summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-03-01 10:01:14 +0100
committerDavid Seifert <soap@gentoo.org>2022-03-01 10:01:14 +0100
commit44a9bc3c408e3c109466d03ea6853bcd9c0530cc (patch)
tree5cd7e19c17ddc21c73886ac4877c58a15257964d /dev-cpp
parentgames-emulation/mgba: Revbump to fix compilation against ffmpeg-5 (diff)
downloadgentoo-44a9bc3c408e3c109466d03ea6853bcd9c0530cc.tar.gz
gentoo-44a9bc3c408e3c109466d03ea6853bcd9c0530cc.tar.bz2
gentoo-44a9bc3c408e3c109466d03ea6853bcd9c0530cc.zip
dev-cpp/kokkos: [QA] use tc-check-openmp
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/kokkos/kokkos-3.1.01-r1.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/dev-cpp/kokkos/kokkos-3.1.01-r1.ebuild b/dev-cpp/kokkos/kokkos-3.1.01-r1.ebuild
index 52828debf318..bc59929572fe 100644
--- a/dev-cpp/kokkos/kokkos-3.1.01-r1.ebuild
+++ b/dev-cpp/kokkos/kokkos-3.1.01-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,13 +17,9 @@ RESTRICT="!test? ( test )"
DEPEND="sys-apps/hwloc:="
RDEPEND="${DEPEND}"
-BDEPEND=""
pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]] && \
- use openmp && ! tc-has-openmp ; then
- die "Need an OpenMP capable compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {