summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/spatialite
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/spatialite')
-rw-r--r--dev-db/spatialite/Manifest2
-rw-r--r--dev-db/spatialite/metadata.xml10
-rw-r--r--dev-db/spatialite/spatialite-2.4.0_rc4.ebuild42
-rw-r--r--dev-db/spatialite/spatialite-3.0.1.ebuild46
4 files changed, 100 insertions, 0 deletions
diff --git a/dev-db/spatialite/Manifest b/dev-db/spatialite/Manifest
new file mode 100644
index 000000000000..a37ec24c4128
--- /dev/null
+++ b/dev-db/spatialite/Manifest
@@ -0,0 +1,2 @@
+DIST libspatialite-2.4.0.tar.gz 865036 SHA256 a9c2a3d9277a6fed13561cf2c1580fef701cfd55336f34eea3f3d46389f7f2c2 SHA512 3e34b2eeedfb0f3a57f3ef33c564cc3bd9391c6f7cc6d7fa7b8e83f920c3a625cfbb33d15d9f2110c7821d964b7b26bb5c06aebd41c3f7ad2bf943d3dea795cf WHIRLPOOL fed91a8501c34a3e0e0a5920049165c081abd050c41b1ef9cb20a8f68571dc85275133d23f798b0b10d88fd6f8623984ee4e18131309d85e1c7512fa9fd3f9d7
+DIST libspatialite-3.0.1.tar.gz 1849723 SHA256 4983d6584069fd5ff0cfcccccee1015088dab2db177c0dc7050ce8306b68f8e6 SHA512 604e5fcb3ac17eb3c69aff5dbf8c77660aecbddc81ab1faa63b0ce069253e3d1c5b6001bd2f2fde5d2f60de9c3758d0d871b9cbcaf1a6d18ceebc0788c166d94 WHIRLPOOL 48f8c84e828ec5e3504e9e347a1fe13c30e852f2127458e1b892ab422f4f0b2fd6857fd50fef51f72fb0851fe7827fac62fe1342e7deac2d7a511501c41321ab
diff --git a/dev-db/spatialite/metadata.xml b/dev-db/spatialite/metadata.xml
new file mode 100644
index 000000000000..dd2d30615678
--- /dev/null
+++ b/dev-db/spatialite/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-geosciences</herd>
+<use>
+ <flag name='geos'>Add the <pkg>sci-libs/geos</pkg> library for exact topological tests</flag>
+ <flag name='proj'>Add the <pkg>sci-libs/proj</pkg> library for reprojection features</flag>
+ <flag name='xls'>Add the <pkg>dev-libs/freexl</pkg> library for xls import support</flag>
+</use>
+</pkgmetadata>
diff --git a/dev-db/spatialite/spatialite-2.4.0_rc4.ebuild b/dev-db/spatialite/spatialite-2.4.0_rc4.ebuild
new file mode 100644
index 000000000000..0ad1585f1676
--- /dev/null
+++ b/dev-db/spatialite/spatialite-2.4.0_rc4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MY_PV=${PV/_rc/-}
+MY_P=lib${P/_rc*}
+
+inherit multilib
+
+DESCRIPTION="A complete Spatial DBMS in a nutshell built upon sqlite"
+HOMEPAGE="http://www.gaia-gis.it/gaia-sins/"
+SRC_URI="http://www.gaia-gis.it/${PN}-${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+geos iconv +proj"
+
+RDEPEND=">=dev-db/sqlite-3.7.5:3[extensions(+)]
+ geos? ( sci-libs/geos )
+ proj? ( sci-libs/proj )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --enable-geocallbacks \
+ --enable-epsg \
+ $(use_enable geos) \
+ $(use_enable iconv) \
+ $(use_enable proj)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/dev-db/spatialite/spatialite-3.0.1.ebuild b/dev-db/spatialite/spatialite-3.0.1.ebuild
new file mode 100644
index 000000000000..ae43cfe7e6e2
--- /dev/null
+++ b/dev-db/spatialite/spatialite-3.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MY_PN="lib${PN}"
+MY_P="${MY_PN}-${PV}"
+
+inherit multilib
+
+DESCRIPTION="A complete Spatial DBMS in a nutshell built upon sqlite"
+HOMEPAGE="http://www.gaia-gis.it/gaia-sins/"
+SRC_URI="http://www.gaia-gis.it/gaia-sins/${MY_PN}-sources/${MY_P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="+geos iconv +proj +xls"
+
+RDEPEND=">=dev-db/sqlite-3.7.5:3[extensions(+)]
+ geos? ( >=sci-libs/geos-3.3 )
+ proj? ( sci-libs/proj )
+ xls? ( dev-libs/freexl )
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --enable-geocallbacks \
+ --enable-epsg \
+ $(use_enable geos) \
+ $(use_enable geos geosadvanced) \
+ $(use_enable iconv) \
+ $(use_enable proj) \
+ $(use_enable xls freexl)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}