summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-31 00:36:06 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-31 01:06:37 +0100
commitd8cbaa62dbf4abc31cc74d2cc12e3d0c7ac9b70a (patch)
treed0dbf038e99c25e5a3060c2ff646102555e6801e /dev-embedded
parentprofiles: Clean py2.7 leftovers (diff)
downloadgentoo-d8cbaa62dbf4abc31cc74d2cc12e3d0c7ac9b70a.tar.gz
gentoo-d8cbaa62dbf4abc31cc74d2cc12e3d0c7ac9b70a.tar.bz2
gentoo-d8cbaa62dbf4abc31cc74d2cc12e3d0c7ac9b70a.zip
*/*: Remove obsolete values from PYTHON_COMPAT
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/esptool/esptool-2.8-r1.ebuild2
-rw-r--r--dev-embedded/esptool/esptool-2.8-r2.ebuild2
-rw-r--r--dev-embedded/esptool/esptool-2.8.ebuild2
-rw-r--r--dev-embedded/esptool/esptool-3.0.ebuild2
-rw-r--r--dev-embedded/libftdi/libftdi-0.20-r1.ebuild2
-rw-r--r--dev-embedded/libftdi/libftdi-1.4-r1.ebuild2
-rw-r--r--dev-embedded/libftdi/libftdi-1.5-r2.ebuild2
-rw-r--r--dev-embedded/libftdi/libftdi-9999.ebuild2
-rw-r--r--dev-embedded/nodemcu-uploader/nodemcu-uploader-0.4.3-r1.ebuild2
-rw-r--r--dev-embedded/platformio/platformio-5.0.1.ebuild2
-rw-r--r--dev-embedded/rpi-eeprom/rpi-eeprom-11.0_p1.ebuild2
11 files changed, 11 insertions, 11 deletions
diff --git a/dev-embedded/esptool/esptool-2.8-r1.ebuild b/dev-embedded/esptool/esptool-2.8-r1.ebuild
index 3c6a1359415f..b5059f85d948 100644
--- a/dev-embedded/esptool/esptool-2.8-r1.ebuild
+++ b/dev-embedded/esptool/esptool-2.8-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} ) # apps work with 3_9 but test depend is not fulfilled
+PYTHON_COMPAT=( python3_{7,8,9} ) # apps work with 3_9 but test depend is not fulfilled
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_SETUPTOOLS=rdepend
diff --git a/dev-embedded/esptool/esptool-2.8-r2.ebuild b/dev-embedded/esptool/esptool-2.8-r2.ebuild
index b30eefa40c21..06aca8c2e285 100644
--- a/dev-embedded/esptool/esptool-2.8-r2.ebuild
+++ b/dev-embedded/esptool/esptool-2.8-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9} )
DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1
diff --git a/dev-embedded/esptool/esptool-2.8.ebuild b/dev-embedded/esptool/esptool-2.8.ebuild
index 11d8c417fa2d..5bcb03d5fe71 100644
--- a/dev-embedded/esptool/esptool-2.8.ebuild
+++ b/dev-embedded/esptool/esptool-2.8.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_7 )
inherit distutils-r1
diff --git a/dev-embedded/esptool/esptool-3.0.ebuild b/dev-embedded/esptool/esptool-3.0.ebuild
index 917cbb15e6ee..364678d8edef 100644
--- a/dev-embedded/esptool/esptool-3.0.ebuild
+++ b/dev-embedded/esptool/esptool-3.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1
diff --git a/dev-embedded/libftdi/libftdi-0.20-r1.ebuild b/dev-embedded/libftdi/libftdi-0.20-r1.ebuild
index f8f5799b48f5..3994d14e7bff 100644
--- a/dev-embedded/libftdi/libftdi-0.20-r1.ebuild
+++ b/dev-embedded/libftdi/libftdi-0.20-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit cmake python-single-r1
if [[ ${PV} == 9999* ]] ; then
diff --git a/dev-embedded/libftdi/libftdi-1.4-r1.ebuild b/dev-embedded/libftdi/libftdi-1.4-r1.ebuild
index ff35d3bfef0c..9a39562ff955 100644
--- a/dev-embedded/libftdi/libftdi-1.4-r1.ebuild
+++ b/dev-embedded/libftdi/libftdi-1.4-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit cmake python-single-r1
if [[ ${PV} == 9999* ]] ; then
diff --git a/dev-embedded/libftdi/libftdi-1.5-r2.ebuild b/dev-embedded/libftdi/libftdi-1.5-r2.ebuild
index 198c985d187e..ad0007487f72 100644
--- a/dev-embedded/libftdi/libftdi-1.5-r2.ebuild
+++ b/dev-embedded/libftdi/libftdi-1.5-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit cmake python-single-r1
MY_P="${PN}1-${PV}"
diff --git a/dev-embedded/libftdi/libftdi-9999.ebuild b/dev-embedded/libftdi/libftdi-9999.ebuild
index 984ebde256da..028e9c9ad1cb 100644
--- a/dev-embedded/libftdi/libftdi-9999.ebuild
+++ b/dev-embedded/libftdi/libftdi-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit cmake python-single-r1
MY_P="${PN}1-${PV}"
diff --git a/dev-embedded/nodemcu-uploader/nodemcu-uploader-0.4.3-r1.ebuild b/dev-embedded/nodemcu-uploader/nodemcu-uploader-0.4.3-r1.ebuild
index ff8b9a4f5286..773459ca6de2 100644
--- a/dev-embedded/nodemcu-uploader/nodemcu-uploader-0.4.3-r1.ebuild
+++ b/dev-embedded/nodemcu-uploader/nodemcu-uploader-0.4.3-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_7 )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
diff --git a/dev-embedded/platformio/platformio-5.0.1.ebuild b/dev-embedded/platformio/platformio-5.0.1.ebuild
index 4a0f1155325f..cf15f6ca563e 100644
--- a/dev-embedded/platformio/platformio-5.0.1.ebuild
+++ b/dev-embedded/platformio/platformio-5.0.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9} )
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_SETUPTOOLS=rdepend
diff --git a/dev-embedded/rpi-eeprom/rpi-eeprom-11.0_p1.ebuild b/dev-embedded/rpi-eeprom/rpi-eeprom-11.0_p1.ebuild
index da82af022728..00133478d075 100644
--- a/dev-embedded/rpi-eeprom/rpi-eeprom-11.0_p1.ebuild
+++ b/dev-embedded/rpi-eeprom/rpi-eeprom-11.0_p1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit python-r1 systemd