summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <Marek.Szuba@cern.ch>2016-04-21 15:13:00 +0200
committerAnthony G. Basile <blueness@gentoo.org>2016-04-23 02:49:57 -0400
commit362b8e3902f4226fe8717d0e95d89096dce9830b (patch)
tree73e2cfc6a656696e4f2fc98e679caf947d1cab8e /dev-go/siphash/siphash-1.0.0.ebuild
parentNew ebuild: dev-go/goptlib. (diff)
downloadgentoo-362b8e3902f4226fe8717d0e95d89096dce9830b.tar.gz
gentoo-362b8e3902f4226fe8717d0e95d89096dce9830b.tar.bz2
gentoo-362b8e3902f4226fe8717d0e95d89096dce9830b.zip
New ebuild: dev-go/siphash.
A Go implementation of SipHash-2.4, a fast short-input PRF created by Jean-Philippe Aumasson and Daniel J. Bernstein. This is one of the dependencies of net-proxy/obfs4proxy. Relevant Gentoo bug: #580628.
Diffstat (limited to 'dev-go/siphash/siphash-1.0.0.ebuild')
-rw-r--r--dev-go/siphash/siphash-1.0.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-go/siphash/siphash-1.0.0.ebuild b/dev-go/siphash/siphash-1.0.0.ebuild
new file mode 100644
index 000000000000..4a59f0445306
--- /dev/null
+++ b/dev-go/siphash/siphash-1.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit golang-build golang-vcs-snapshot
+
+EGO_SRC=github.com/dchest/siphash
+EGO_PN=${EGO_SRC}/...
+EGIT_COMMIT="v${PV}"
+SRC_URI="https://github.com/dchest/siphash/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+DESCRIPTION="Go implementation of SipHash-2.4"
+HOMEPAGE="https://github.com/dchest/siphash"
+
+KEYWORDS="~amd64"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""