summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-29 10:42:15 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 08:59:19 +0100
commit3fa93e2da6bf628798396460b3030543851d54cb (patch)
tree1eab7ffe492379b416b0dd05fe20a212b1a00bd0 /dev-haskell/cabal/cabal-3.0.1.0.ebuild
parentdev-haskell/semigroups: bump up to 0.18.5 (diff)
downloadgentoo-3fa93e2da6bf628798396460b3030543851d54cb.tar.gz
gentoo-3fa93e2da6bf628798396460b3030543851d54cb.tar.bz2
gentoo-3fa93e2da6bf628798396460b3030543851d54cb.zip
dev-haskell/cabal: bump up to 3.0.1.0
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/cabal/cabal-3.0.1.0.ebuild')
-rw-r--r--dev-haskell/cabal/cabal-3.0.1.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/cabal/cabal-3.0.1.0.ebuild b/dev-haskell/cabal/cabal-3.0.1.0.ebuild
new file mode 100644
index 000000000000..88d667c8f674
--- /dev/null
+++ b/dev-haskell/cabal/cabal-3.0.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+#hackport: flags: -parsec-struct-diff
+
+CABAL_FEATURES="lib profile" # Drop test-suite: circular depend
+CABAL_FEATURES+=" nocabaldep" # in case installed Cabal is broken
+inherit haskell-cabal
+
+MY_PN="Cabal"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A framework for packaging Haskell software"
+HOMEPAGE="http://www.haskell.org/cabal/"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# keep in sync with ghc-8.8
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RESTRICT=test # circular deps: cabal -> quickcheck -> cabal
+
+RDEPEND=">=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
+ >=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/parsec-3.1.13.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/semigroups-0.18.3:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
+ >=dev-haskell/text-1.2.3.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+PATCHES=("${FILESDIR}"/${PN}-2.0.0.2-no-bootstrap.patch)
+
+CABAL_CORE_LIB_GHC_PV="PM:8.8.2 PM:8.8.3 PM:8.8.4"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-parsec-struct-diff
+}