summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-20 09:01:11 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-20 09:01:17 +0100
commitd1a398ab759489923d700779afec89b4059da46e (patch)
treef115566777172874368c506fd3ccab232a6191ac /dev-haskell/configfile
parentapp-misc/nnn: Version bump (v3.4) (diff)
downloadgentoo-d1a398ab759489923d700779afec89b4059da46e.tar.gz
gentoo-d1a398ab759489923d700779afec89b4059da46e.tar.bz2
gentoo-d1a398ab759489923d700779afec89b4059da46e.zip
dev-haskell/configfile: drop IUSE=buildtests
buildtests pulls in unmaintained testpack. Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/configfile')
-rw-r--r--dev-haskell/configfile/configfile-1.1.4.ebuild17
-rw-r--r--dev-haskell/configfile/metadata.xml18
2 files changed, 8 insertions, 27 deletions
diff --git a/dev-haskell/configfile/configfile-1.1.4.ebuild b/dev-haskell/configfile/configfile-1.1.4.ebuild
index 27a4c529df83..5e1022976cf6 100644
--- a/dev-haskell/configfile/configfile-1.1.4.ebuild
+++ b/dev-haskell/configfile/configfile-1.1.4.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-# ebuild generated by hackport 0.4.4.9999
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: -buildtests
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
MY_PN="ConfigFile"
@@ -18,22 +19,20 @@ SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="buildtests"
+IUSE=""
RDEPEND=">=dev-haskell/missingh-1.0.0:=[profile?]
dev-haskell/mtl:=[profile?]
dev-haskell/parsec:=[profile?]
>=dev-lang/ghc-7.4.1:=
- buildtests? ( dev-haskell/hunit:=[profile?]
- dev-haskell/testpack:=[profile?] )
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.2.3
+ >=dev-haskell/cabal-1.2
"
S="${WORKDIR}/${MY_P}"
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag buildtests buildtests)
+ --flag=-buildtests
}
diff --git a/dev-haskell/configfile/metadata.xml b/dev-haskell/configfile/metadata.xml
index c430e789391c..b7878815d80d 100644
--- a/dev-haskell/configfile/metadata.xml
+++ b/dev-haskell/configfile/metadata.xml
@@ -5,22 +5,4 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Parser and writer for handling sectioned config files in
- Haskell.
-
- The ConfigFile module works with configuration files in a standard
- format that is easy for the user to edit, easy for the programmer
- to work with, yet remains powerful and flexible. It is inspired by,
- and compatible with, Python's ConfigParser module. It uses files
- that resemble Windows .INI-style files, but with numerous
- improvements.
-
- ConfigFile provides simple calls to both read and write config files.
- It's possible to make a config file parsable by this module,
- the Unix shell, and make.
- </longdescription>
- <use>
- <flag name="buildtests">Build the executable to run unit tests.</flag>
- </use>
</pkgmetadata>