summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:08:44 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:53 +0100
commit85f5a795a1419698307cc64ec92b9ff9abb5a9be (patch)
treef5640799e90c8feab2099b7da609495c4a6eb394 /dev-haskell/microstache
parentdev-haskell/microlens: add 0.4.13.0 (diff)
downloadgentoo-85f5a795a1419698307cc64ec92b9ff9abb5a9be.tar.gz
gentoo-85f5a795a1419698307cc64ec92b9ff9abb5a9be.tar.bz2
gentoo-85f5a795a1419698307cc64ec92b9ff9abb5a9be.zip
dev-haskell/microstache: add 1.0.2.3-r1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/microstache')
-rw-r--r--dev-haskell/microstache/Manifest2
-rw-r--r--dev-haskell/microstache/metadata.xml10
-rw-r--r--dev-haskell/microstache/microstache-1.0.2.3-r1.ebuild34
3 files changed, 40 insertions, 6 deletions
diff --git a/dev-haskell/microstache/Manifest b/dev-haskell/microstache/Manifest
index 4ba4c1c46884..55c362496844 100644
--- a/dev-haskell/microstache/Manifest
+++ b/dev-haskell/microstache/Manifest
@@ -1,2 +1,4 @@
DIST microstache-1.0.2-rev3.cabal 2873 BLAKE2B 8d389ffbb9216b19f0d91fa690230e9bb2a79a74f4742394a8d7fe8ec2e0344c7485ebcd40b516dcdce25dd275ff16eae67bdc22bba0c60da54f7ff1199623ba SHA512 2c952588bbd355f313ae63eba4bb0cea38f36da8e0a7f29be6a841836e32cf05ef86d1bbc2b21bc871b218778ca521484ca146cf0f83e9053e0b00d821258e10
+DIST microstache-1.0.2.3-rev2.cabal 3247 BLAKE2B 78c1fd439c104821dd753945f2a6069ca4908cc41ee0bd9d1b0c6b02335bfdccbecbaf9a73f2dece5eb1ea45a5f16911274b491675c0e0758c1b2bf94f0916b8 SHA512 7349239c7b3156d37379caa13e8fba38ab06a97b7959570554eee098f82e5a583e74f432b5ce2589e2f15e8a76c86cd45b0e1e2f356e1c199ddfbffa4990bfab
+DIST microstache-1.0.2.3.tar.gz 22421 BLAKE2B 9d243f5545d95cf48c3acaebbf05f978b69c78e73b0dfd80c94dc5f118033b7917e47b3a9850fdba36d4b46eafed729971c0a4647a109b93996c2990de3bcd34 SHA512 c50fa66a019116ca81e63de59951df29316c39c50d3672197353987ac431f63cc97ee26adb1f8f31ffdad7409f58e2a369502da0e0484af0b0632b6ac8deac4d
DIST microstache-1.0.2.tar.gz 21333 BLAKE2B 05f726b88c96e47157e76705bf6961bf27f81cdee8f3c7860e9f24f368e450862d854a6a47492da179ed6830006059100470e029183f11164e1042766111cb6d SHA512 bbf1de864c88809cfd159a679ec1709c7fb523e2b3ac91232e2cabb9a4bf2eda0913666b3a6ab81b6ba9c2488ce1200cb6b43e21a7f475d2dc20f9854c47a61e
diff --git a/dev-haskell/microstache/metadata.xml b/dev-haskell/microstache/metadata.xml
index a9b24934427e..02d7514695e0 100644
--- a/dev-haskell/microstache/metadata.xml
+++ b/dev-haskell/microstache/metadata.xml
@@ -5,10 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Mustache templates for Haskell.
-
- Based on @stache@ library, which uses @megaparsec@.
- This library uses @parsec@, thus the name: @microstache@.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">microstache</remote-id>
+ <remote-id type="github">haskellari/microstache</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/microstache/microstache-1.0.2.3-r1.ebuild b/dev-haskell/microstache/microstache-1.0.2.3-r1.ebuild
new file mode 100644
index 000000000000..10399293c94f
--- /dev/null
+++ b/dev-haskell/microstache/microstache-1.0.2.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_HACKAGE_REVISION=2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Mustache templates for Haskell"
+HOMEPAGE="https://github.com/haskellari/microstache"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/parsec-3.1.11:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.5:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.11:=[profile?] <dev-haskell/vector-0.14:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ >=dev-haskell/aeson-0.11:=[profile?] <dev-haskell/aeson-2.3:=[profile?]
+ >=dev-haskell/text-1.2.3.0:=[profile?] <dev-haskell/text-2.1:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( dev-haskell/aeson
+ >=dev-haskell/base-orphans-0.8.7 <dev-haskell/base-orphans-0.10
+ >=dev-haskell/tasty-1.4.0.1 <dev-haskell/tasty-1.5
+ >=dev-haskell/tasty-hunit-0.10.0.3 <dev-haskell/tasty-hunit-0.11
+ dev-haskell/text )
+"