summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/bctsp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/bctsp')
-rw-r--r--dev-java/bctsp/Manifest1
-rw-r--r--dev-java/bctsp/bctsp-1.45-r1.ebuild44
-rw-r--r--dev-java/bctsp/metadata.xml8
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-java/bctsp/Manifest b/dev-java/bctsp/Manifest
new file mode 100644
index 000000000000..fd5ee77a66da
--- /dev/null
+++ b/dev-java/bctsp/Manifest
@@ -0,0 +1 @@
+DIST bctsp-jdk15-145.tar.gz 100494 SHA256 1bd01deef63cb95affed9e0653bef8a3392aaf5857f4e03f00481b2e82e3d4c4 SHA512 8e06598b6286502a6cf908f60b9bcae134dca070869c58e408746470e1f4f80ad8bca8c6f2fe5265fed051b5ddbeb710154ae7bf3a50fff2980c6b562ba6a606 WHIRLPOOL 5b453c1403a8251ec7a2eafd43f4c96c14e241396f248ca17bf533a9fd8142812845b168bb07c36aaf1b038da40c8e2c93646c24d6d717bb4e9e38de8600e677
diff --git a/dev-java/bctsp/bctsp-1.45-r1.ebuild b/dev-java/bctsp/bctsp-1.45-r1.ebuild
new file mode 100644
index 000000000000..ad001c777c09
--- /dev/null
+++ b/dev-java/bctsp/bctsp-1.45-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="${PN}-jdk15-${PV/./}"
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="http://www.bouncycastle.org/java.html"
+SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ dev-java/bcprov:1.45
+ dev-java/bcmail:1.45"
+
+RDEPEND="${COMMON_DEPEND}
+ >=virtual/jre-1.5"
+
+DEPEND="${COMMON_DEPEND}
+ >=virtual/jdk-1.5
+ app-arch/unzip"
+
+S="${WORKDIR}"/${MY_P}
+
+JAVA_GENTOO_CLASSPATH="bcprov-1.45,bcmail-1.45"
+
+src_unpack() {
+ default
+ cd "${S}" || die
+ unpack ./src.zip
+}
+
+java_prepare() {
+ # Remove tests
+ rm -R org/bouncycastle/tsp/test || die
+}
diff --git a/dev-java/bctsp/metadata.xml b/dev-java/bctsp/metadata.xml
new file mode 100644
index 000000000000..82a57ccd5243
--- /dev/null
+++ b/dev-java/bctsp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+