summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-07-13 18:20:27 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-07-28 20:25:59 +0200
commit58ff5db50bc57e9636238f45a684b98ec2206c27 (patch)
tree710daaf5eee4343480ccc74c74f4a4361c54aa82 /dev-java/commons-imaging
parentsys-cluster/kube-router: add myself as a maintainer (diff)
downloadgentoo-58ff5db50bc57e9636238f45a684b98ec2206c27.tar.gz
gentoo-58ff5db50bc57e9636238f45a684b98ec2206c27.tar.bz2
gentoo-58ff5db50bc57e9636238f45a684b98ec2206c27.zip
dev-java/commons-imaging: add 1.0_alpha3
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/26388 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/commons-imaging')
-rw-r--r--dev-java/commons-imaging/Manifest1
-rw-r--r--dev-java/commons-imaging/commons-imaging-1.0_alpha3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-java/commons-imaging/Manifest b/dev-java/commons-imaging/Manifest
index 636f8ef3213e..2d8bdd19015e 100644
--- a/dev-java/commons-imaging/Manifest
+++ b/dev-java/commons-imaging/Manifest
@@ -1 +1,2 @@
DIST commons-imaging-1.0-alpha2-src.tar.gz 39798631 BLAKE2B 01d0754689896a1f2ff1401cac7d9f59a6bbb245c0880f24f857efc53975c1203c6857d7a5d107763741a2dec7fb48c4faa258786f574cf2f3c5acca251e368b SHA512 f2479e0dc726a8d1193f4eef6289efe493cfbbe257054b5a13e929f5785f7a2c9c937e3f379e0f0066c591d18be27d12f1e5157e789eebab78fba489cc81e688
+DIST commons-imaging-1.0-alpha3-src.tar.gz 39966281 BLAKE2B f0fbb6d7ae0c12be19fe13d3ff4e1cced5acfe7ea72326528c67b57fade73c0acee3eb8eaa62b3d40c473c0c2faf7f60ec190bc0954c5159405358bfac4efd42 SHA512 16300adb5873fef464bedfdce7e1368f52add8d33087f059667840880b8666024feeecdb278a53d5c3d8e76d01ab921ea146d41ca688757f0cf0c2f2b32b0d53
diff --git a/dev-java/commons-imaging/commons-imaging-1.0_alpha3.ebuild b/dev-java/commons-imaging/commons-imaging-1.0_alpha3.ebuild
new file mode 100644
index 000000000000..338fc76ea1a4
--- /dev/null
+++ b/dev-java/commons-imaging/commons-imaging-1.0_alpha3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri mirror://apache/commons/imaging/source/commons-imaging-1.0-alpha3-src.tar.gz --slot 0 --keywords "~amd64 ~x86" --ebuild commons-imaging-1.0_alpha3.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.apache.commons:commons-imaging:1.0-alpha2"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Apache Commons Imaging (previously Sanselan) is a pure-Java image library."
+HOMEPAGE="https://commons.apache.org/proper/commons-imaging/"
+SRC_URI="mirror://apache/commons/imaging/source/commons-imaging-${PV/_/-}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Compile dependencies
+# POM: pom.xml
+# test? commons-io:commons-io:2.7 -> >=dev-java/commons-io-2.11.0:1
+# test? org.hamcrest:hamcrest:2.2 -> !!!artifactId-not-found!!!
+# test? org.junit.jupiter:junit-jupiter:5.6.2 -> !!!groupId-not-found!!!
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( {LICENSE,NOTICE,RELEASE-NOTES}.txt README.md )
+
+S="${WORKDIR}/${P/_/-}-src"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_RESOURCE_DIRS="src/main/resources"
+JAVA_AUTOMATIC_MODULE_NAME="org.apache.commons.imaging"