summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-11-05 22:36:48 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-11-05 22:49:22 +0000
commitad0a422afe82e5873408b3325cbec9b68e03b210 (patch)
tree667b5706d8930239b521940461736b7579f72d80 /dev-java/guava/guava-20.0.ebuild
parentdev-java/j2objc-annotations: New package, required by guava (diff)
downloadgentoo-ad0a422afe82e5873408b3325cbec9b68e03b210.tar.gz
gentoo-ad0a422afe82e5873408b3325cbec9b68e03b210.tar.bz2
gentoo-ad0a422afe82e5873408b3325cbec9b68e03b210.zip
dev-java/guava: Version bump to 20.0, EAPI bump to 6
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-java/guava/guava-20.0.ebuild')
-rw-r--r--dev-java/guava/guava-20.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/guava/guava-20.0.ebuild b/dev-java/guava/guava-20.0.ebuild
new file mode 100644
index 000000000000..e93c74e7ac1a
--- /dev/null
+++ b/dev-java/guava/guava-20.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A collection of Google's core Java libraries"
+HOMEPAGE="https://github.com/google/guava"
+SRC_URI="https://github.com/google/guava/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="${PV%.*}"
+KEYWORDS="~amd64 ~x86"
+
+CP_DEPEND="
+ dev-java/animal-sniffer-annotations:0
+ dev-java/error-prone-annotations:0
+ dev-java/jsr305:0
+"
+
+RDEPEND="${CP_DEPEND}
+ >=virtual/jre-1.7"
+
+DEPEND="${CP_DEPEND}
+ >=virtual/jdk-1.7
+ dev-java/j2objc-annotations:0"
+
+S="${WORKDIR}/${P}/${PN}"
+JAVA_SRC_DIR="src"
+
+src_configure() {
+ JAVA_GENTOO_CLASSPATH_EXTRA=$(java-pkg_getjars --build-only j2objc-annotations)
+}