summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-06-18 12:32:39 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-06-20 08:49:25 +0200
commitd17f91c51bae75d66a813ea50dc2f92888dd6873 (patch)
tree7dcfb3c0ad4ba10a43e217460e5037f023ab42b3 /dev-java/jctools-core
parentdev-java/conversant-disruptor: add 1.2.20 (diff)
downloadgentoo-d17f91c51bae75d66a813ea50dc2f92888dd6873.tar.gz
gentoo-d17f91c51bae75d66a813ea50dc2f92888dd6873.tar.bz2
gentoo-d17f91c51bae75d66a813ea50dc2f92888dd6873.zip
dev-java/jctools-core: add 3.1.0
This is the highest version which can run tests without kotlinx-lincheck. Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/jctools-core')
-rw-r--r--dev-java/jctools-core/Manifest1
-rw-r--r--dev-java/jctools-core/jctools-core-3.1.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-java/jctools-core/Manifest b/dev-java/jctools-core/Manifest
index ee8ea275b3b6..75ab7c5f1a9a 100644
--- a/dev-java/jctools-core/Manifest
+++ b/dev-java/jctools-core/Manifest
@@ -1 +1,2 @@
+DIST jctools-3.1.0.tar.gz 4204148 BLAKE2B 88f8f5395470072571de64ee3d696e90c1fbf22a6e9c1424463bfb8b497dd3d47f8d0fcc9a039acec8380ac52a3d445789257d5a1071e49e6963c59d156065e2 SHA512 bf69387732dea043e6e5fa44fe60a5f80ef5ae9d32ebb39ac16353e5bd82502b3b6e5564a8bd9f3b8ad073a95ff984ae55133884ebeea9d0b9a777c488af2a74
DIST jctools-core-2.0.2.tar.gz 4136573 BLAKE2B 6ca4c276422b24b18256b35606b6e59e8be53b77fe0b757e4f46dc4e0bdab0ea8fbb8c58e84794c689aa1df29a80aa847b6baf7cda430f2657720ecb5d60e99f SHA512 734905d6847664a08557fa9807766bfe2cd57e9562f1dc0d908c9fffc627c1cb7576ac079715004da9a1f2ee958c8373caf60c110ef3de8f7da5bb04775f6f7f
diff --git a/dev-java/jctools-core/jctools-core-3.1.0.ebuild b/dev-java/jctools-core/jctools-core-3.1.0.ebuild
new file mode 100644
index 000000000000..834d6fa686a6
--- /dev/null
+++ b/dev-java/jctools-core/jctools-core-3.1.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/JCTools/JCTools/archive/v3.1.0.tar.gz --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild jctools-core-3.1.0.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="org.jctools:jctools-core:3.0.1"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java Concurrency Tools Core Library"
+HOMEPAGE="https://jctools.github.io/JCTools/"
+SRC_URI="https://github.com/JCTools/JCTools/archive/v${PV}.tar.gz -> jctools-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Compile dependencies
+# POM: pom.xml
+# test? com.google.guava:guava-testlib:21.0 -> >=dev-java/guava-testlib-30.1.1:0
+# test? junit:junit:4.12 -> >=dev-java/junit-4.13.2:4
+# test? org.hamcrest:hamcrest-all:1.3 -> !!!artifactId-not-found!!!
+
+DEPEND=">=virtual/jdk-1.8:*
+ test? (
+ dev-java/guava-testlib:0
+ dev-java/hamcrest-library:1.3
+ )"
+
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( ../{README,RELEASE-NOTES}.md )
+
+S="${WORKDIR}/JCTools-${PV}/jctools-core"
+
+JAVA_SRC_DIR="src/main/java"
+
+JAVA_TEST_GENTOO_CLASSPATH="guava-testlib,hamcrest-library-1.3,junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
+
+# Using the defaults of java-pkg-simple would skip more than half the number of tests.
+src_test() {
+ # These tests would fail and are not run by "mvn test".
+ # "org.jctools.queues.MpqSanityTest"
+ # "org.jctools.queues.QueueSanityTest"
+ # "org.jctools.queues.ScQueueRemoveTest"
+ # "org.jctools.util.TestUtil"
+ pushd src/test/java || die
+ local JAVA_TEST_RUN_ONLY=$(find * \
+ \( -name "*Test*.java" \
+ -o -name "nbsi_tester.java" \
+ -o -name "nbhs_tester.java" \)\
+ ! -name "MpqSanityTest.java" \
+ ! -name "QueueSanityTest.java" \
+ ! -name "ScQueueRemoveTest.java" \
+ ! -name "TestUtil.java" \
+ )
+ popd
+ JAVA_TEST_RUN_ONLY="${JAVA_TEST_RUN_ONLY//.java}"
+ JAVA_TEST_RUN_ONLY="${JAVA_TEST_RUN_ONLY//\//.}"
+ java-pkg-simple_src_test
+}
+
+src_install() {
+ default # https://bugs.gentoo.org/789582
+ java-pkg-simple_src_install
+}