summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/junitperf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/junitperf')
-rw-r--r--dev-java/junitperf/Manifest1
-rw-r--r--dev-java/junitperf/junitperf-1.9.1-r1.ebuild46
-rw-r--r--dev-java/junitperf/metadata.xml5
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-java/junitperf/Manifest b/dev-java/junitperf/Manifest
new file mode 100644
index 000000000000..08b6abf329b2
--- /dev/null
+++ b/dev-java/junitperf/Manifest
@@ -0,0 +1 @@
+DIST junitperf-1.9.1.zip 110600 SHA256 ff350b8b6bcf79826b96ab786303dc22f0d096d2e9d333c52ac567cc4d26b79a SHA512 35fd3cddf5643ede31a89f39e0149ceb5a07c97521bcb4e661fce32b08a5299064f6b52828889d4918485f3ca000f6020dd6cec802d8b1579f46bd861ad74b1b WHIRLPOOL 0ad8e653f87d5cd34f1c3630a7a185934cf8ae13a8fee05f0cfcd352d6f6aa8896bf8cce3e013e33cb73fa253c16fdad6c5b3edf16e49b3eaf5cd3cd56cf80cb
diff --git a/dev-java/junitperf/junitperf-1.9.1-r1.ebuild b/dev-java/junitperf/junitperf-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..62537d3e2342
--- /dev/null
+++ b/dev-java/junitperf/junitperf-1.9.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc test source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Simple framework to write repeatable tests"
+SRC_URI="http://www.clarkware.com/software/${P}.zip"
+HOMEPAGE="http://www.clarkware.com/software/JUnitPerf.html"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+
+IUSE=""
+
+COMMON_DEP="=dev-java/junit-3.8*"
+
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ test? ( dev-java/ant-junit )
+ ${COMMON_DEP}"
+
+src_unpack () {
+ unpack ${A}
+ cd "${S}"/lib || die
+ rm -fv *.jar || die
+ java-pkg_jar-from junit
+}
+
+EANT_DOC_TARGET=""
+
+src_test() {
+ ANT_TASKS="ant-junit" eant test
+}
+
+src_install() {
+ java-pkg_dojar lib/${PN}.jar
+ dodoc README || die
+ use doc && java-pkg_dojavadoc docs/api
+ use source && java-pkg_dosrc src/app/*
+}
diff --git a/dev-java/junitperf/metadata.xml b/dev-java/junitperf/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/junitperf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>