summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-22 20:00:56 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-22 22:03:03 +0100
commit0dbd28d2e94105b4faaea44fc578ecbc8874efb4 (patch)
treeae9af68d370ed5f86adbfe793c7df9f1802802fa /dev-lang/mercury/mercury-13.05.1.ebuild
parentx11-terms/rxvt-unicode: Use ecvs_clean to clean workdir (diff)
downloadgentoo-0dbd28d2e94105b4faaea44fc578ecbc8874efb4.tar.gz
gentoo-0dbd28d2e94105b4faaea44fc578ecbc8874efb4.tar.bz2
gentoo-0dbd28d2e94105b4faaea44fc578ecbc8874efb4.zip
dev-lang/mercury: Use ecvs_clean to clean workdir
* add missing die Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-lang/mercury/mercury-13.05.1.ebuild')
-rw-r--r--dev-lang/mercury/mercury-13.05.1.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-lang/mercury/mercury-13.05.1.ebuild b/dev-lang/mercury/mercury-13.05.1.ebuild
index c0fcf9dd7b20..44f38dcacd48 100644
--- a/dev-lang/mercury/mercury-13.05.1.ebuild
+++ b/dev-lang/mercury/mercury-13.05.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -34,7 +34,7 @@ S="${WORKDIR}"/${MY_P}
SITEFILE=50${PN}-gentoo.el
src_prepare() {
- cd "${WORKDIR}"
+ cd "${WORKDIR}" || die
EPATCH_FORCE=yes
EPATCH_SUFFIX=patch
epatch "${WORKDIR}"/${PV}
@@ -43,7 +43,7 @@ src_prepare() {
"${S}"/scripts/Mmake.vars.in \
|| die "sed libdir failed"
- cd "${S}"
+ cd "${S}" || die
eautoconf
}
@@ -117,7 +117,7 @@ src_test() {
TWS="${S}"
fi
- cd "${S}"/tests
+ cd "${S}"/tests || die
sed -e "s:@WORKSPACE@:${TWS}:" < WS_FLAGS.ws > WS_FLAGS \
|| die "sed WORKSPACE failed"
@@ -183,8 +183,7 @@ src_install() {
doins -r samples/java_interface || die
fi
- rm -rf $(find "${D}"/usr/share/doc/${PF}/samples \
- -name CVS -o -name .cvsignore)
+ ecvs_clean "${D}"/usr/share/doc/${PF}/samples
fi
}