summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-13 01:41:45 +0000
committerSam James <sam@gentoo.org>2022-01-13 01:42:08 +0000
commitbe02856a46e00bbb861fd3c651cac42c2b7697d0 (patch)
treefd8315e8d644cb29e2711f3cf7f28cfa1e73383b /dev-lang/mono
parentprofiles/arch/arm64: unmask gnome[classic] (diff)
downloadgentoo-be02856a46e00bbb861fd3c651cac42c2b7697d0.tar.gz
gentoo-be02856a46e00bbb861fd3c651cac42c2b7697d0.tar.bz2
gentoo-be02856a46e00bbb861fd3c651cac42c2b7697d0.zip
dev-lang/mono: fix automagic ccache usage
This is for users to enable, not for build systems to do it based on whether ccache is installed (which leads to sandbox issues anyway). Closes: https://bugs.gentoo.org/830562 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/files/mono-6.12.0.122-disable-automagic-ccache.patch22
-rw-r--r--dev-lang/mono/mono-6.12.0.122.ebuild3
2 files changed, 24 insertions, 1 deletions
diff --git a/dev-lang/mono/files/mono-6.12.0.122-disable-automagic-ccache.patch b/dev-lang/mono/files/mono-6.12.0.122-disable-automagic-ccache.patch
new file mode 100644
index 000000000000..b92592f6ea32
--- /dev/null
+++ b/dev-lang/mono/files/mono-6.12.0.122-disable-automagic-ccache.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/831079
+--- a/mono/btls/CMakeLists.txt
++++ b/mono/btls/CMakeLists.txt
+@@ -12,11 +12,6 @@ endif()
+ enable_language(C)
+ enable_language(CXX)
+
+-find_program(CCACHE_PROGRAM ccache)
+-if(CCACHE_PROGRAM)
+- set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE "${CCACHE_PROGRAM}")
+-endif()
+-
+ if (MSVC OR CYGWIN)
+ set(BTLS_HOST_WIN32 1)
+ endif ()
+@@ -129,4 +124,4 @@ endif ()
+
+ if (CYGWIN)
+ target_link_libraries (mono-btls-shared wsock32 ws2_32)
+-endif ()
+\ No newline at end of file
++endif ()
diff --git a/dev-lang/mono/mono-6.12.0.122.ebuild b/dev-lang/mono/mono-6.12.0.122.ebuild
index 449d4aebe3b2..97ee904ee535 100644
--- a/dev-lang/mono/mono-6.12.0.122.ebuild
+++ b/dev-lang/mono/mono-6.12.0.122.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -36,6 +36,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-5.12-try-catch.patch
+ "${FILESDIR}"/${PN}-6.12.0.122-disable-automagic-ccache.patch
)
pkg_pretend() {