summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-03 21:03:47 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-03 21:29:57 +0100
commit5002ab447454bf2d51ca3a7aa54fbeed5f508e0d (patch)
treec88bf9906f7af0f2a3b6f6635f078afdce58c247 /dev-lang/nim
parentdev-lang/nim: drop old 1.6.4 (diff)
downloadgentoo-5002ab447454bf2d51ca3a7aa54fbeed5f508e0d.tar.gz
gentoo-5002ab447454bf2d51ca3a7aa54fbeed5f508e0d.tar.bz2
gentoo-5002ab447454bf2d51ca3a7aa54fbeed5f508e0d.zip
dev-lang/nim: drop IUSE=debug
Closes: https://bugs.gentoo.org/889448 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/nim')
-rw-r--r--dev-lang/nim/nim-1.6.10-r1.ebuild (renamed from dev-lang/nim/nim-1.6.10.ebuild)6
-rw-r--r--dev-lang/nim/nim-1.6.6-r3.ebuild (renamed from dev-lang/nim/nim-1.6.6-r2.ebuild)14
-rw-r--r--dev-lang/nim/nim-1.6.8-r1.ebuild (renamed from dev-lang/nim/nim-1.6.8.ebuild)6
3 files changed, 14 insertions, 12 deletions
diff --git a/dev-lang/nim/nim-1.6.10.ebuild b/dev-lang/nim/nim-1.6.10-r1.ebuild
index 00b90b784ff9..4634c652fad3 100644
--- a/dev-lang/nim/nim-1.6.10.ebuild
+++ b/dev-lang/nim/nim-1.6.10-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,7 +18,7 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="debug experimental"
+IUSE="experimental"
RESTRICT="test" # need to sort out depends and numerous failures
# BDEPEND="sys-process/parallel"
@@ -49,7 +49,7 @@ nim_gen_config() {
gcc.cpp.options.linker:"${LDFLAGS}"
$([[ "${NOCOLOR}" == true || "${NOCOLOR}" == yes ]] && echo '--colors:"off"')
- -d:"$(usex debug debug release)"
+ -d:"release"
--parallelBuild:"$(makeopts_jobs)"
EOF
}
diff --git a/dev-lang/nim/nim-1.6.6-r2.ebuild b/dev-lang/nim/nim-1.6.6-r3.ebuild
index 79f9edc5c376..6314b192e44d 100644
--- a/dev-lang/nim/nim-1.6.6-r2.ebuild
+++ b/dev-lang/nim/nim-1.6.6-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,13 +9,16 @@ DESCRIPTION="compiled, garbage-collected systems programming language"
HOMEPAGE="https://nim-lang.org/"
SRC_URI="
https://nim-lang.org/download/${P}.tar.xz
- experimental? ( https://git.sr.ht/~cyber/${PN}-patches/archive/${PV}.tar.gz -> ${PN}-patches-${PV}.tar.gz )
+ experimental? (
+ https://git.sr.ht/~cyber/${PN}-patches/archive/${PV}.tar.gz
+ -> ${PN}-patches-${PV}.tar.gz
+ )
"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="debug experimental"
+IUSE="experimental"
RESTRICT="test" # need to sort out depends and numerous failures
# BDEPEND="sys-process/parallel"
@@ -46,7 +49,7 @@ nim_gen_config() {
gcc.cpp.options.linker:"${LDFLAGS}"
$([[ "${NOCOLOR}" == true || "${NOCOLOR}" == yes ]] && echo '--colors:"off"')
- -d:"$(usex debug debug release)"
+ -d:"release"
--parallelBuild:"$(makeopts_jobs)"
EOF
}
@@ -55,8 +58,7 @@ src_prepare() {
default
# note: there are consumers in the ::guru overlay
- use experimental && \
- eapply "${WORKDIR}"/${PN}-patches-${PV}
+ use experimental && eapply "${WORKDIR}"/${PN}-patches-${PV}
}
src_configure() {
diff --git a/dev-lang/nim/nim-1.6.8.ebuild b/dev-lang/nim/nim-1.6.8-r1.ebuild
index 00b90b784ff9..4634c652fad3 100644
--- a/dev-lang/nim/nim-1.6.8.ebuild
+++ b/dev-lang/nim/nim-1.6.8-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,7 +18,7 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="debug experimental"
+IUSE="experimental"
RESTRICT="test" # need to sort out depends and numerous failures
# BDEPEND="sys-process/parallel"
@@ -49,7 +49,7 @@ nim_gen_config() {
gcc.cpp.options.linker:"${LDFLAGS}"
$([[ "${NOCOLOR}" == true || "${NOCOLOR}" == yes ]] && echo '--colors:"off"')
- -d:"$(usex debug debug release)"
+ -d:"release"
--parallelBuild:"$(makeopts_jobs)"
EOF
}