summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathy Vanvoorden <mathy@vanvoorden.be>2017-11-07 23:35:49 +0100
committerCraig Andrews <candrews@gentoo.org>2017-12-20 14:47:16 -0500
commit6632bce8e713fab5f91ca75798ba9ae546f58c16 (patch)
treeb4dcf1d6401af7418a82a46e4acc2e95d4001387 /dev-lang
parentnet-p2p/go-ethereum: Cleanup old version (diff)
downloadgentoo-6632bce8e713fab5f91ca75798ba9ae546f58c16.tar.gz
gentoo-6632bce8e713fab5f91ca75798ba9ae546f58c16.tar.bz2
gentoo-6632bce8e713fab5f91ca75798ba9ae546f58c16.zip
dev-lang/solidity: version bump to 0.4.18
The previous patch needed to build valid releases is no longer needed since upstream now provides valid release tarballs. A new patch is added to remove the download and static compile of jsoncpp during the build. The dependency has been fixed on 1.8.1 since the code does not compile with a newer version. Upstream actually fixes to 1.7.7 but that version isn't in the tree and 1.8.1 works. Closes: https://bugs.gentoo.org/629998 Closes: https://bugs.gentoo.org/627940 Package-Manager: Portage-2.3.8, Repoman-2.3.4
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/solidity/Manifest1
-rw-r--r--dev-lang/solidity/files/solidity-0.4.18-fix-cmake-external-jsoncpp.diff15
-rw-r--r--dev-lang/solidity/solidity-0.4.18.ebuild37
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-lang/solidity/Manifest b/dev-lang/solidity/Manifest
index 8f5a3e2236b8..28e0008baeb5 100644
--- a/dev-lang/solidity/Manifest
+++ b/dev-lang/solidity/Manifest
@@ -1 +1,2 @@
+DIST solidity-0.4.18.tar.gz 1005571 BLAKE2B b7748f1e9ceb260ee5c02a5e6ddb7a3387a6f1df252889258045cf03e3cab365f1ac41c7e75805a49b71beceb88439855c53b6c59a81d610db48f9fe5256da55 SHA512 aa88060567a50fa833a81ef2c9ce9614ed0fddd9dc82c1546998dacd9a7cad1863882aa0700d830f80fe52bd91659a9fa07434af193624206876ba7224c34eb7
DIST solidity-0.4.2.tar.gz 495039 BLAKE2B ee09fc457d64727468eedb3d9150ad123f8e7cbfe80a71de0a730f43bd3b0b71f2ceb01ba189b542e273cfe4c1bccef3f0e0c5077512992c058729f52fded015 SHA512 2ef2e58775e22eefce867ee73dbab61f54def1edd95e089ec3a388b5aaba316c44fe18b92d45e070014b9df6e450b2b27fe78434f5db40f0476c505b2541572c
diff --git a/dev-lang/solidity/files/solidity-0.4.18-fix-cmake-external-jsoncpp.diff b/dev-lang/solidity/files/solidity-0.4.18-fix-cmake-external-jsoncpp.diff
new file mode 100644
index 000000000000..1acafc9d9e36
--- /dev/null
+++ b/dev-lang/solidity/files/solidity-0.4.18-fix-cmake-external-jsoncpp.diff
@@ -0,0 +1,15 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 24bea3b3..4326927b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -18,7 +18,9 @@ include(EthCcache)
+
+ # Let's find our dependencies
+ include(EthDependencies)
+-include(jsoncpp)
++find_package(PkgConfig REQUIRED)
++pkg_check_modules(JSONCPP jsoncpp)
++include_directories("${JSONCPP_INCLUDE_DIRS}")
+
+ find_package(Threads)
+
diff --git a/dev-lang/solidity/solidity-0.4.18.ebuild b/dev-lang/solidity/solidity-0.4.18.ebuild
new file mode 100644
index 000000000000..8a36d44a9092
--- /dev/null
+++ b/dev-lang/solidity/solidity-0.4.18.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="The Solidity Contract-Oriented Programming Language"
+HOMEPAGE="https://github.com/ethereum/solidity"
+SRC_URI="https://github.com/ethereum/${PN}/releases/download/v${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="=dev-libs/jsoncpp-1.8.1:=
+ >=dev-libs/boost-1.54:=
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ # Upstream downloads and builds a static jsoncpp during build
+ "${FILESDIR}"/${P}-fix-cmake-external-jsoncpp.diff
+)
+
+src_configure() {
+ local mycmakeargs=(
+ "-DBoost_USE_STATIC_LIBS=off"
+ )
+
+ cmake-utils_src_configure
+}