summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-01-04 21:15:35 +0100
committerSam James <sam@gentoo.org>2023-01-05 05:19:56 +0000
commit3c1e535842253bbc891d9607d0b6af220772e82b (patch)
treed0ec511018dc687d271a0cc9a44511b098a8c1ea /dev-libs/capstone
parentmail-filter/spamassassin: Install 4.0.0 compat geoip.cf (diff)
downloadgentoo-3c1e535842253bbc891d9607d0b6af220772e82b.tar.gz
gentoo-3c1e535842253bbc891d9607d0b6af220772e82b.tar.bz2
gentoo-3c1e535842253bbc891d9607d0b6af220772e82b.zip
dev-libs/capstone: drop 5.0_rc2-r1
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/capstone')
-rw-r--r--dev-libs/capstone/capstone-5.0_rc2-r1.ebuild82
1 files changed, 0 insertions, 82 deletions
diff --git a/dev-libs/capstone/capstone-5.0_rc2-r1.ebuild b/dev-libs/capstone/capstone-5.0_rc2-r1.ebuild
deleted file mode 100644
index f8b94f595aef..000000000000
--- a/dev-libs/capstone/capstone-5.0_rc2-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit cmake distutils-r1 toolchain-funcs
-
-DESCRIPTION="disassembly/disassembler framework + bindings"
-HOMEPAGE="http://www.capstone-engine.org/"
-SRC_URI="https://github.com/capstone-engine/capstone/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/5" # libcapstone.so.5
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-IUSE="python test"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
- python? ( dev-python/setuptools[${PYTHON_USEDEP}] )
-"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-distutils_enable_tests setup.py
-
-S=${WORKDIR}/${P/_rc/-rc}
-
-PATCHES=(
- "${FILESDIR}"/${P}-pkgconfig.patch
-)
-
-if [[ ${PV} == *_rc* ]]; then
- # Upstream doesn't flag release candidates (bug 858350)
- QA_PKGCONFIG_VERSION=""
-fi
-
-wrap_python() {
- local phase=$1
- shift
-
- if use python; then
- pushd bindings/python >/dev/null || die
- distutils-r1_${phase} "$@"
- popd >/dev/null || die
- fi
-}
-
-src_prepare() {
- tc-export RANLIB
- cmake_src_prepare
-
- wrap_python ${FUNCNAME}
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCAPSTONE_BUILD_TESTS="$(usex test)"
- )
- cmake_src_configure
-
- wrap_python ${FUNCNAME}
-}
-
-src_compile() {
- cmake_src_compile
-
- wrap_python ${FUNCNAME}
-}
-
-src_test() {
- cmake_src_test
-
- wrap_python ${FUNCNAME}
-}
-
-src_install() {
- cmake_src_install
-
- wrap_python ${FUNCNAME}
-}