summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro@users.noreply.github.com>2022-10-07 16:10:49 -0400
committerSam James <sam@gentoo.org>2022-10-30 09:33:27 +0000
commite62ae148d712c4ce23398991048959d054b589bc (patch)
treee85d5f79d6959b043dbe428eed04b7014025a35e /dev-libs/dbus-c++
parentdev-util/gef: use docs.eclass (diff)
downloadgentoo-e62ae148d712c4ce23398991048959d054b589bc.tar.gz
gentoo-e62ae148d712c4ce23398991048959d054b589bc.tar.bz2
gentoo-e62ae148d712c4ce23398991048959d054b589bc.zip
dev-libs/dbus-c++: add tests
Current tests are a no-op due to not including them in TESTS for whatever unknown reason. Same on Debian. Tests pass on alpha but need virtx. Bug: https://bugs.gentoo.org/873487 Signed-off-by: Matoro Mahri <matoro@users.noreply.github.com> Closes: https://github.com/gentoo/gentoo/pull/27679 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/dbus-c++')
-rw-r--r--dev-libs/dbus-c++/dbus-c++-0.9.0-r5.ebuild15
-rw-r--r--dev-libs/dbus-c++/files/dbus-c++-0.9.0-enable-tests.patch22
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-libs/dbus-c++/dbus-c++-0.9.0-r5.ebuild b/dev-libs/dbus-c++/dbus-c++-0.9.0-r5.ebuild
index bd749ca5481f..a2a4913da27c 100644
--- a/dev-libs/dbus-c++/dbus-c++-0.9.0-r5.ebuild
+++ b/dev-libs/dbus-c++/dbus-c++-0.9.0-r5.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit multilib-minimal
+inherit multilib-minimal autotools virtualx
DESCRIPTION="Provides a C++ API for D-BUS"
HOMEPAGE="https://sourceforge.net/projects/dbus-cplusplus/"
@@ -24,7 +24,8 @@ DEPEND="${RDEPEND}
dev-util/cppunit[${MULTILIB_USEDEP}]"
BDEPEND="
virtual/pkgconfig
- doc? ( app-doc/doxygen )"
+ doc? ( app-doc/doxygen )
+ test? ( sys-apps/dbus[X,${MULTILIB_USEDEP}] )"
S="${WORKDIR}/lib${P}"
@@ -32,8 +33,14 @@ PATCHES=(
"${FILESDIR}"/${P}-gcc-4.7.patch #424707
"${FILESDIR}"/${PN}-gcc7.patch #622790
"${FILESDIR}"/${P}-gcc12.patch
+ "${FILESDIR}"/${PN}-0.9.0-enable-tests.patch #873487
)
+src_prepare() {
+ default
+ eautoreconf
+}
+
multilib_src_configure() {
# TODO : add ecore multilib support if/when it is multilibified
ECONF_SOURCE="${S}" econf \
@@ -55,6 +62,10 @@ multilib_src_configure() {
fi
}
+src_test() {
+ virtx multilib-minimal_src_test
+}
+
multilib_src_install_all() {
use doc && HTML_DOCS=( doc/html/. )
einstalldocs
diff --git a/dev-libs/dbus-c++/files/dbus-c++-0.9.0-enable-tests.patch b/dev-libs/dbus-c++/files/dbus-c++-0.9.0-enable-tests.patch
new file mode 100644
index 000000000000..827332c9f679
--- /dev/null
+++ b/dev-libs/dbus-c++/files/dbus-c++-0.9.0-enable-tests.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/873487
+https://github.com/gentoo/gentoo/pull/27679
+
+diff --git a/test/functional/Test1/Makefile.am b/test/functional/Test1/Makefile.am
+index 3269751..50dd2a9 100644
+--- a/test/functional/Test1/Makefile.am
++++ b/test/functional/Test1/Makefile.am
+@@ -40,3 +40,4 @@ AM_CPPFLAGS =
+
+ ## File created by the gnome-build tools
+
++TESTS = $(noinst_PROGRAMS)
+diff --git a/test/generator/Makefile.am b/test/generator/Makefile.am
+index 6c2403d..c6781aa 100644
+--- a/test/generator/Makefile.am
++++ b/test/generator/Makefile.am
+@@ -38,3 +38,5 @@ dist-hook:
+
+ MAINTAINERCLEANFILES = \
+ Makefile.in
++
++TESTS = $(noinst_PROGRAMS)