summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-18 19:22:06 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 20:50:38 +0200
commitf5e5f289c9282b4ace8b0b63c28d55b9d9fa706d (patch)
tree3d24a6e527b854b0fb6ae24ebee93810a7276e86 /dev-libs/level-zero
parentdev-lang/ocaml: remove unused patch (diff)
downloadgentoo-f5e5f289c9282b4ace8b0b63c28d55b9d9fa706d.tar.gz
gentoo-f5e5f289c9282b4ace8b0b63c28d55b9d9fa706d.tar.bz2
gentoo-f5e5f289c9282b4ace8b0b63c28d55b9d9fa706d.zip
dev-libs/level-zero: remove unused patch(es)
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/level-zero')
-rw-r--r--dev-libs/level-zero/files/level-zero-1.16.14-spdlog-libfmt.patch60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-libs/level-zero/files/level-zero-1.16.14-spdlog-libfmt.patch b/dev-libs/level-zero/files/level-zero-1.16.14-spdlog-libfmt.patch
deleted file mode 100644
index 4d9264e0c49c..000000000000
--- a/dev-libs/level-zero/files/level-zero-1.16.14-spdlog-libfmt.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-Find the system copy of spdlog which then tells us how to link
-against both it & libfmt correctly, rather than accidentally
-picking up system spdlog headers and nothing else (defines, needed
-libraries, etc) when (for some reason?) FetchContent fails and we don't
-realise it.
-
-TODO: Figure out why FetchContent(?) failing doesn't kill the build
-TODO: Add a proper option for this to use the system copy/not
-
-Bug: https://bugs.gentoo.org/930157
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -57,9 +57,6 @@ elseif(Git_FOUND)
- endif()
- endif()
-
--include(FetchContent)
--set(SPDLOG_ROOT "${FETCHCONTENT_BASE_DIR}/spdlog-src")
--
- # Update other relevant variables to include the patch
- set(PROJECT_VERSION "${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH}")
- set(CMAKE_PROJECT_VERSION_PATCH "${PROJECT_VERSION_PATCH}")
-@@ -166,7 +163,6 @@ endif()
-
- include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include)
- include_directories(${CMAKE_CURRENT_SOURCE_DIR}/source/wrapper/include)
--include_directories(${SPDLOG_ROOT}/include)
-
- include_directories("${CMAKE_CURRENT_SOURCE_DIR}")
-
-diff --git a/source/utils/CMakeLists.txt b/source/utils/CMakeLists.txt
-index cb6cfb1..4e486d8 100644
---- a/source/utils/CMakeLists.txt
-+++ b/source/utils/CMakeLists.txt
-@@ -1,23 +1,11 @@
- # Copyright (C) 2024 Intel Corporation
- # SPDX-License-Identifier: MIT
-
--include(FetchContent)
--set(SPDLOG_REPO https://github.com/gabime/spdlog)
--set(SPDLOG_TAG v1.13.0)
--FetchContent_Declare(
-- spdlog
-- GIT_REPOSITORY ${SPDLOG_REPO}
-- GIT_TAG ${SPDLOG_TAG}
--)
--FetchContent_makeAvailable(spdlog)
-+find_package(spdlog)
-
- add_library(utils
-- STATIC
- "logging.h"
- "logging.cpp"
- )
-
--target_include_directories(utils
-- PUBLIC
-- ${FETCHCONTENT_BASE_DIR}/spdlog-src/include
--)
-+target_link_libraries(utils spdlog::spdlog)