summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever.fta@gmail.com>2018-10-16 11:41:54 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-10-16 11:44:56 +0200
commit54613df62106ec3c776eb3d6e429f0ad26b8b526 (patch)
tree750fc777bdad3cc2fe02d69f139a33e67af6fdea /dev-libs/libinput
parentdev-libs/libmspack-0.6_alpha-r0: add ~alpha keyword (diff)
downloadgentoo-54613df62106ec3c776eb3d6e429f0ad26b8b526.tar.gz
gentoo-54613df62106ec3c776eb3d6e429f0ad26b8b526.tar.bz2
gentoo-54613df62106ec3c776eb3d6e429f0ad26b8b526.zip
dev-libs/libinput: implement usage of python-any-r1.eclass
Closes: https://bugs.gentoo.org/665722 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/libinput-1.12.1-r1.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/dev-libs/libinput/libinput-1.12.1-r1.ebuild b/dev-libs/libinput/libinput-1.12.1-r1.ebuild
index 6da9ac2bd8d6..f62f6c75ec66 100644
--- a/dev-libs/libinput/libinput-1.12.1-r1.ebuild
+++ b/dev-libs/libinput/libinput-1.12.1-r1.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit meson udev
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+
+inherit meson python-any-r1 udev
DESCRIPTION="Library to handle input devices in Wayland"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
@@ -26,9 +28,11 @@ RDEPEND="
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? (
- dev-python/CommonMark
- dev-python/recommonmark
- dev-python/sphinx
+ $(python_gen_any_dep '
+ dev-python/CommonMark[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ')
>=app-doc/doxygen-1.8.3
>=media-gfx/graphviz-2.38.0
)
@@ -38,6 +42,12 @@ DEPEND="${RDEPEND}
# dev-util/valgrind
# sys-libs/libunwind )
+python_check_deps() {
+ has_version "dev-python/CommonMark[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
src_configure() {
# gui can be built but will not be installed
local emesonargs=(