summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2021-04-02 14:25:49 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-04-28 10:08:38 +0300
commitf4303599956d379071cd1dbe9059b1b813131c05 (patch)
treec0f2fbeac0df4d8e3c2780dfb82154185f9148c9 /dev-libs/libite/libite-2.4.0.ebuild
parentapp-benchmarks/siege: bump to 4.0.9 (diff)
downloadgentoo-f4303599956d379071cd1dbe9059b1b813131c05.tar.gz
gentoo-f4303599956d379071cd1dbe9059b1b813131c05.tar.bz2
gentoo-f4303599956d379071cd1dbe9059b1b813131c05.zip
dev-libs/libite: add 2.4.0
Also, disable static library build. Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/libite/libite-2.4.0.ebuild')
-rw-r--r--dev-libs/libite/libite-2.4.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/libite/libite-2.4.0.ebuild b/dev-libs/libite/libite-2.4.0.ebuild
new file mode 100644
index 000000000000..2caf2e8389ae
--- /dev/null
+++ b/dev-libs/libite/libite-2.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A collection of useful BSD APIs"
+HOMEPAGE="https://github.com/troglobit/libite"
+SRC_URI="https://github.com/troglobit/libite/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ econf --enable-static=no
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+ rm "${D}/usr/share/doc/${PF}/LICENSE" || die
+}