summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-22 23:33:43 +0000
committerSam James <sam@gentoo.org>2022-11-22 23:33:43 +0000
commite1a3128b6ca82ec6f9632448200afb8a2a5bd495 (patch)
tree08b4a32d9c6d21edce5bc8cfb4316cf9a87219ad /dev-libs/liblognorm
parentapp-arch/rzip: fix configure w/ clang 16 (diff)
downloadgentoo-e1a3128b6ca82ec6f9632448200afb8a2a5bd495.tar.gz
gentoo-e1a3128b6ca82ec6f9632448200afb8a2a5bd495.tar.bz2
gentoo-e1a3128b6ca82ec6f9632448200afb8a2a5bd495.zip
dev-libs/liblognorm: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/liblognorm')
-rw-r--r--dev-libs/liblognorm/files/liblognorm-2.0.6-configure-clang16.patch21
-rw-r--r--dev-libs/liblognorm/liblognorm-2.0.6-r1.ebuild (renamed from dev-libs/liblognorm/liblognorm-2.0.6.ebuild)14
2 files changed, 28 insertions, 7 deletions
diff --git a/dev-libs/liblognorm/files/liblognorm-2.0.6-configure-clang16.patch b/dev-libs/liblognorm/files/liblognorm-2.0.6-configure-clang16.patch
new file mode 100644
index 000000000000..3ba63017e18a
--- /dev/null
+++ b/dev-libs/liblognorm/files/liblognorm-2.0.6-configure-clang16.patch
@@ -0,0 +1,21 @@
+https://bugzilla.redhat.com/show_bug.cgi?id=2141801
+https://src.fedoraproject.org/rpms/liblognorm/c/cdaf4de866002343f4011bb05c71f764258948a7?branch=rawhide
+
+"""
+Submitted to Adiscon via ticket system. See:
+
+ <https://bugzilla.redhat.com/show_bug.cgi?id=2141801>
+"""
+--- a/configure.ac
++++ b/configure.ac
+@@ -38,7 +38,7 @@ m4_ifdef([AX_IS_RELEASE], [
+ # Checks for libraries.
+ save_LIBS=$LIBS
+ LIBS=
+-AC_SEARCH_LIBS(clock_getm4_defn([AC_AUTOCONF_VERSION]), [2.68]time, rt)
++AC_SEARCH_LIBS(clock_gettime, rt)
+ LIBS=$save_LIBS
+
+ # Checks for header files.
+
+
diff --git a/dev-libs/liblognorm/liblognorm-2.0.6.ebuild b/dev-libs/liblognorm/liblognorm-2.0.6-r1.ebuild
index 63346c79252e..f3648a4f4e3d 100644
--- a/dev-libs/liblognorm/liblognorm-2.0.6.ebuild
+++ b/dev-libs/liblognorm/liblognorm-2.0.6-r1.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
inherit autotools
DESCRIPTION="Fast samples-based log normalization library"
HOMEPAGE="https://www.liblognorm.com"
-if [[ ${PV} == "9999" ]]; then
+if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/rsyslog/${PN}.git"
inherit git-r3
@@ -26,9 +26,8 @@ RDEPEND="
>=dev-libs/libestr-0.1.3
>=dev-libs/libfastjson-0.99.2:=
"
-
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
>=sys-devel/autoconf-archive-2015.02.04
virtual/pkgconfig
doc? ( >=dev-python/sphinx-1.2.2 )
@@ -38,6 +37,7 @@ DOCS=( ChangeLog )
PATCHES=(
"${FILESDIR}/${P}-sphinx-5.patch"
+ "${FILESDIR}/${P}-configure-clang16.patch"
)
src_prepare() {
@@ -67,11 +67,11 @@ src_test() {
find "${S}"/tests -type f -name '*.sh' \! -perm -111 -exec chmod a+x '{}' \; || \
die "Failed to adjust test scripts permission"
- emake --jobs 1 check
+ emake -j1 check
}
src_install() {
default
- find "${ED}"usr/lib* -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}